sigrok: add recipes
authorGrazvydas Ignotas <notasas@gmail.com>
Wed, 1 Nov 2017 17:50:18 +0000 (19:50 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Wed, 1 Nov 2017 17:50:18 +0000 (19:50 +0200)
recipes/libzip/libzip_1.3.0.bb [new file with mode: 0644]
recipes/sigrok/libserialport_0.1.1.bb [new file with mode: 0644]
recipes/sigrok/libsigrok_0.5.0.bb [new file with mode: 0644]
recipes/sigrok/sigrok-cli_0.7.0.bb [new file with mode: 0644]
recipes/sigrok/sigrok.inc [new file with mode: 0644]

diff --git a/recipes/libzip/libzip_1.3.0.bb b/recipes/libzip/libzip_1.3.0.bb
new file mode 100644 (file)
index 0000000..b476562
--- /dev/null
@@ -0,0 +1,15 @@
+DESCRIPTION = "C library for reading, creating, and modifying zip archives"
+SECTION = "libs"
+HOMEPAGE = "http://www.nih.at/libzip"
+LICENSE = "BSD"
+DEPENDS = "zlib"
+
+SRC_URI = "http://www.nih.at/${PN}/${PN}-${PV}.tar.xz"
+
+inherit autotools
+
+do_stage() {
+       autotools_stage_all
+}
+
+SRC_URI[md5sum] = "bf0342c919bea07ba8197a1691a4d2da"
diff --git a/recipes/sigrok/libserialport_0.1.1.bb b/recipes/sigrok/libserialport_0.1.1.bb
new file mode 100644 (file)
index 0000000..686fbdc
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "C library intended to take care of the OS-specific details when writing software that uses serial ports"
+SECTION = "libs"
+HOMEPAGE = "https://sigrok.org"
+LICENSE = "LGPLv3+"
+
+require sigrok.inc
+
+inherit autotools
+
+do_stage() {
+       autotools_stage_all
+}
+
+SRC_URI[md5sum] = "b93f0325a6157198152b5bd7e8182b51"
diff --git a/recipes/sigrok/libsigrok_0.5.0.bb b/recipes/sigrok/libsigrok_0.5.0.bb
new file mode 100644 (file)
index 0000000..72694e8
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "shared library which provides basic hardware access drivers for logic analyzers, as well as input/output file format support"
+SECTION = "libs"
+HOMEPAGE = "https://sigrok.org"
+LICENSE = "GPLv3+"
+DEPENDS = "glib-2.0 libzip libserialport libusb1"
+
+require sigrok.inc
+
+inherit autotools
+
+# some problem against libusb1
+EXTRA_OECONF = "--without-libftdi"
+# too old gcc?
+EXTRA_OECONF += "--disable-lecroy-xstream"
+
+do_stage() {
+       autotools_stage_all
+}
+
+SRC_URI[md5sum] = "0e27c89b6b7374fa9a571d6227f6a54a"
diff --git a/recipes/sigrok/sigrok-cli_0.7.0.bb b/recipes/sigrok/sigrok-cli_0.7.0.bb
new file mode 100644 (file)
index 0000000..a39f450
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "command-line frontend for the sigrok software"
+SECTION = "console/utils"
+HOMEPAGE = "https://sigrok.org"
+LICENSE = "GPLv3+"
+DEPENDS = "glib-2.0 libsigrok"
+
+require sigrok.inc
+
+inherit autotools
+
+# some problem against libusb1
+# EXTRA_OECONF = "--without-libftdi"
+
+do_stage() {
+       autotools_stage_all
+}
+
+SRC_URI[md5sum] = "77cb745e2fa239c7bd1ea81e2d67ede9"
diff --git a/recipes/sigrok/sigrok.inc b/recipes/sigrok/sigrok.inc
new file mode 100644 (file)
index 0000000..5f57814
--- /dev/null
@@ -0,0 +1 @@
+SRC_URI = "http://sigrok.org/download/source/${PN}/${PN}-${PV}.tar.gz"