bluez4: add a patch to fix CVE-2017-1000250
authorGrazvydas Ignotas <notasas@gmail.com>
Sat, 16 Sep 2017 22:40:38 +0000 (01:40 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 16 Sep 2017 22:40:38 +0000 (01:40 +0300)
recipes/bluez/bluez4-4.99/0001-sdp-Fix-Out-of-bounds-heap-read-in-service_search_at.patch [new file with mode: 0644]
recipes/bluez/bluez4_4.99.bb

diff --git a/recipes/bluez/bluez4-4.99/0001-sdp-Fix-Out-of-bounds-heap-read-in-service_search_at.patch b/recipes/bluez/bluez4-4.99/0001-sdp-Fix-Out-of-bounds-heap-read-in-service_search_at.patch
new file mode 100644 (file)
index 0000000..719aaeb
--- /dev/null
@@ -0,0 +1,27 @@
+From 9e009647b14e810e06626dde7f1bb9ea3c375d09 Mon Sep 17 00:00:00 2001
+From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+Date: Wed, 13 Sep 2017 10:01:40 +0300
+Subject: [PATCH] sdp: Fix Out-of-bounds heap read in service_search_attr_req
+ function
+
+Check if there is enough data to continue otherwise return an error.
+---
+ src/sdpd-request.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sdpd-request.c b/src/sdpd-request.c
+index 1eefdce..318d044 100644
+--- a/src/sdpd-request.c
++++ b/src/sdpd-request.c
+@@ -917,7 +917,7 @@ static int service_search_attr_req(sdp_req_t *req, sdp_buf_t *buf)
+       } else {
+               /* continuation State exists -> get from cache */
+               sdp_buf_t *pCache = sdp_get_cached_rsp(cstate);
+-              if (pCache) {
++              if (pCache && cstate->cStateValue.maxBytesSent < pCache->data_size) {
+                       uint16_t sent = MIN(max, pCache->data_size - cstate->cStateValue.maxBytesSent);
+                       pResponse = pCache->data;
+                       memcpy(buf->data, pResponse + cstate->cStateValue.maxBytesSent, sent);
+-- 
+2.7.4
+
index 8969349..2ddcce9 100644 (file)
@@ -1,6 +1,6 @@
 require bluez4.inc
 
-PR = "r13"
+PR = "r14"
 
 SRC_URI += "file://bluetooth.conf \
             file://sbc_mmx.patch;patch=1 \
@@ -13,6 +13,7 @@ SRC_URI += "file://bluetooth.conf \
             file://0001-hciattach_tialt-Implement-texas_change_speed-functio.patch;patch=1 \
             file://firmware_path.patch;patch=1 \
             file://enable_socket_api.patch;patch=1 \
+            file://0001-sdp-Fix-Out-of-bounds-heap-read-in-service_search_at.patch;patch=1 \
 "
 
 SRC_URI[md5sum] = "570aa10692ed890aa0a4297b37824912"