hexedit: add 1.2.13
authorGrazvydas Ignotas <notasas@gmail.com>
Tue, 3 May 2016 23:57:27 +0000 (02:57 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Tue, 3 May 2016 23:57:27 +0000 (02:57 +0300)
from meta-openembedded meta-oe/recipes-extended/

recipes/hexedit/hexedit/0001-don-t-strip-when-installing.patch [new file with mode: 0644]
recipes/hexedit/hexedit_1.2.13.bb [new file with mode: 0644]

diff --git a/recipes/hexedit/hexedit/0001-don-t-strip-when-installing.patch b/recipes/hexedit/hexedit/0001-don-t-strip-when-installing.patch
new file mode 100644 (file)
index 0000000..a384b05
--- /dev/null
@@ -0,0 +1,30 @@
+From cc67246ca6839e5b3f6a286f10ed24c225b77a5e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Eric=20B=C3=A9nard?= <eric@eukrea.com>
+Date: Thu, 4 Jul 2013 12:34:32 +0200
+Subject: [PATCH] don't strip when installing
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Eric BĂ©nard <eric@eukrea.com>
+
+Upstream-Status: Inappropriate [configuration]
+---
+ Makefile.in |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 159463e..735cc72 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -42,6 +42,6 @@ distclean: clean
+ install: $(PRODUCT)
+       $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+-      $(INSTALL) -s -m 755 $(PRODUCT) $(DESTDIR)$(bindir)
++      $(INSTALL) -m 755 $(PRODUCT) $(DESTDIR)$(bindir)
+       $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
+       $(INSTALL) -m 644 $(PRODUCT).1 $(DESTDIR)$(mandir)/man1
+-- 
+1.7.10.4
+
diff --git a/recipes/hexedit/hexedit_1.2.13.bb b/recipes/hexedit/hexedit_1.2.13.bb
new file mode 100644 (file)
index 0000000..9abad51
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY = "view and edit files in hexadecimal or in ASCII"
+HOMEPAGE = "http://rigaux.org/hexedit.html"
+SECTION = "console/utils"
+LICENSE = "GPLv2+"
+DEPENDS = "ncurses"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+SRC_URI = "http://rigaux.org/${BP}.src.tgz \
+    file://0001-don-t-strip-when-installing.patch;patch=1 "
+
+SRC_URI[md5sum] = "a5af1378d028512a9cad27a5ba3e15f9"
+SRC_URI[sha256sum] = "6a126da30a77f5c0b08038aa7a881d910e3b65d13767fb54c58c983963b88dd7"
+
+inherit autotools
+
+S = "${WORKDIR}/${BPN}"