xf86-video-omapfb: add pandora specific screen blanking
authorGrazvydas Ignotas <notasas@gmail.com>
Sat, 21 Aug 2010 19:37:14 +0000 (22:37 +0300)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 21 Aug 2010 19:38:12 +0000 (22:38 +0300)
recipes/xorg-driver/xf86-video-omapfb/pandora_backlight_dim.patch [new file with mode: 0644]
recipes/xorg-driver/xf86-video-omapfb_git.bb

diff --git a/recipes/xorg-driver/xf86-video-omapfb/pandora_backlight_dim.patch b/recipes/xorg-driver/xf86-video-omapfb/pandora_backlight_dim.patch
new file mode 100644 (file)
index 0000000..f722682
--- /dev/null
@@ -0,0 +1,19 @@
+diff --git a/src/omapfb-driver.c b/src/omapfb-driver.c
+index 7a57221..fa97724 100644
+--- a/src/omapfb-driver.c
++++ b/src/omapfb-driver.c
+@@ -788,7 +788,13 @@ OMAPFBLeaveVT(int scrnIndex, int flags)
+ static Bool
+ OMAPFBSaveScreen(ScreenPtr pScreen, int mode)
+ {
+-      xf86Msg(X_NOT_IMPLEMENTED, "%s: Dim backlight?\n", __FUNCTION__);
++      /* call Pandora specific script */
++      char cmd[256];
++
++      snprintf(cmd, sizeof(cmd), "/usr/pandora/scripts/op_lid.sh %d",
++               (mode == SCREEN_SAVER_ON || mode == SCREEN_SAVER_CYCLE) ? 1 : 0);
++      system(cmd);
++
+       return TRUE;
+ }
index 7c723fa..cab2922 100644 (file)
@@ -2,13 +2,14 @@ require xorg-driver-video.inc
 
 DESCRIPTION = "X.Org X server -- OMAP display driver"
 
-PR_append = "e"
+PR_append = "f"
 
 SRCREV = "db636c8436265c3d86c5b8e00785e45d55825c80"
 PV = "0.1.1+${PR}+gitr${SRCREV}"
 PE = "1"
 
 SRC_URI = "git://git.pingu.fi/xf86-video-omapfb.git;protocol=http \
+           file://pandora_backlight_dim.patch;patch=1 \
           "
 
 S = "${WORKDIR}/git"