ipkg-utils-native: Switch to non-legacy staging
authorTom Rini <tom_rini@mentor.com>
Thu, 8 Jul 2010 20:40:33 +0000 (13:40 -0700)
committerGrazvydas Ignotas <notasas@gmail.com>
Mon, 6 Jul 2015 20:34:30 +0000 (23:34 +0300)
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Conflicts:
recipes/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb

recipes/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb

index 758814f..2a72466 100644 (file)
@@ -1,16 +1,18 @@
 require ipkg-utils_${PV}.bb
 
-RDEPENDS = ""
-PR = "r21"
+RDEPENDS_${PN} = ""
+PR = "r23"
 
 inherit native
 
+NATIVE_INSTALL_WORKS = "1"
+
 # Avoid circular dependencies from package_ipk.bbclass
 PACKAGES = ""
 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ipkg-utils"
 INSTALL += "arfile.py"
 
-do_stage() {
+do_install() {
         for i in ${INSTALL}; do
                 install -m 0755 $i ${STAGING_BINDIR}
         done