coreutils: Build and package df of coreutils
authorHolger Hans Peter Freyther <zecke@selfish.org>
Thu, 4 Dec 2008 12:22:41 +0000 (13:22 +0100)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Thu, 4 Dec 2008 12:49:01 +0000 (13:49 +0100)
    - df can only be build if one of the many statvfs,fsusage
      was is present. These tests work by executing a test application
      and that is obviously not working out when cross compiling
    - all linux (glibc, eglibc, uclibc) should have the bsize in the
      struct statvfs... and this will enable the build of df.

packages/coreutils/coreutils_5.3.0.bb
packages/coreutils/coreutils_6.0.bb
site/common-linux

index 42ac2c1..2a9b091 100644 (file)
@@ -1,6 +1,6 @@
 require coreutils.inc
 
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
            file://install-cross.patch;patch=1;pnum=0 \
@@ -10,7 +10,7 @@ SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
            file://futimens.patch;patch=1"
 
 # [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
+bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
                env expand expr factor fmt fold groups head hostid id install \
                join link logname md5sum mkfifo nice nl nohup od paste pathchk \
                pinky pr printenv printf ptx readlink seq sha1sum shred sort \
index 59afd67..57a6864 100644 (file)
@@ -1,5 +1,7 @@
 require coreutils.inc
 
+PR = "r1"
+
 DEFAULT_PREFERENCE = "-1"
 
 SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
@@ -8,7 +10,7 @@ SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
           file://onceonly.m4"
 
 # [ gets a special treatment and is not included in this
-bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \
+bindir_progs = "basename cksum comm csplit cut df dir dircolors dirname du \
                env expand expr factor fmt fold groups head hostid id install \
                join link logname md5sum mkfifo nice nl nohup od paste pathchk \
                pinky pr printenv printf ptx readlink seq sha1sum shred sort \
index 1465b5f..8d915d0 100644 (file)
@@ -6,3 +6,7 @@ samba_cv_HAVE_IFACE_AIX=${samba_cv_HAVE_IFACE_AIX=no}
 samba_cv_HAVE_IFACE_IFCONF=${samba_cv_HAVE_IFACE_IFCONF=yes}
 samba_cv_HAVE_IFACE_IFREQ=${samba_cv_HAVE_IFACE_IFREQ=yes}
 samba_cv_HAVE_IRIX_SPECIFIC_CAPABILITIES=${samba_cv_HAVE_IRIX_SPECIFIC_CAPABILITIES=no}
+
+# coreutils
+fu_cv_sys_stat_statfs2_bsize=${fu_cv_sys_stat_statfs2_bsize=yes}
+