ipkg-utils: convert mtime to int before comparing it
authorEnrico Scholz <enrico.scholz@sigma-chemnitz.de>
Tue, 15 Jun 2010 12:43:54 +0000 (14:43 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Mon, 6 Jul 2015 20:35:53 +0000 (23:35 +0300)
The st_mtime attribute (which is a float) is compared against a value
from the timestamp database, which was stored as an integer there.

When working on a filesystem with precise timestamps the comparision
will fail nearly everytime hence.

Although it might be possible to enhance the database to store the
fractional part too, this will complicate things more than we would
gain by this change.

Signed-off-by: Enrico Scholz <enrico.scholz@sigma-chemnitz.de>
recipes/ipkg-utils/ipkg-utils-native_1.6+cvs20050404.bb
recipes/ipkg-utils/ipkg-utils/ipkg-make-index-track-stamps.patch
recipes/ipkg-utils/ipkg-utils_1.6+cvs20050404.bb

index 19eb6f8..3a6aaed 100644 (file)
@@ -1,7 +1,7 @@
 require ipkg-utils_${PV}.bb
 
 RDEPENDS_${PN} = ""
-PR = "r24"
+PR = "r25"
 
 inherit native
 
index ad6df4f..68758ed 100644 (file)
@@ -53,7 +53,7 @@ Index: ipkg-utils/ipkg-make-index
 +     fnameStat = os.stat(filename)
       if old_pkg_hash.has_key(basename):
 -          if (verbose):
-+          if pkgsStamps.has_key(basename) and fnameStat.st_mtime == pkgsStamps[basename]:
++          if pkgsStamps.has_key(basename) and int(fnameStat.st_mtime) == pkgsStamps[basename]:
 +            if (verbose):
                 sys.stderr.write("Found %s in Packages\n" % (filename,))
 -          pkg = old_pkg_hash[basename]
index 5350da8..cdb8355 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "GPL"
 CONFLICTS = "ipkg-link"
 RDEPENDS_${PN} = "python"
 SRCDATE = "20050930"
-PR = "r26"
+PR = "r27"
 
 TARGET_CC_ARCH += "${LDFLAGS}"