ca-certificates_20170717: hacks for old oe
[openembedded.git] / recipes / ca-certificates / ca-certificates_20170717.bb
index 59e7d51..d5f32e2 100644 (file)
@@ -4,28 +4,29 @@ SSL-based applications to check for the authenticity of SSL connections. \
 This derived from Debian's CA Certificates."
 HOMEPAGE = "http://packages.debian.org/sid/ca-certificates"
 SECTION = "misc"
-LICENSE = "GPL-2.0+ MPL-2.0"
+LICENSE = "GPL-2.0+ MPL-2.0"
 LIC_FILES_CHKSUM = "file://debian/copyright;md5=e7358b9541ccf3029e9705ed8de57968"
 
 # This is needed to ensure we can run the postinst at image creation time
 DEPENDS = ""
-DEPENDS_class-native = "openssl-native"
-DEPENDS_class-nativesdk = "openssl-native"
+DEPENDS_virtclass-native = "openssl-native"
+DEPENDS_virtclass-nativesdk = "openssl-native"
 # Need c_rehash from openssl and run-parts from debianutils
 PACKAGE_WRITE_DEPS += "openssl-native debianutils-native"
 
 SRCREV = "34b8e19e541b8af4076616b2e170c7a70cdaded0"
 
-SRC_URI = "git://anonscm.debian.org/collab-maint/ca-certificates.git \
-           file://0002-update-ca-certificates-use-SYSROOT.patch \
-           file://0001-update-ca-certificates-don-t-use-Debianisms-in-run-p.patch \
-           file://update-ca-certificates-support-Toybox.patch \
-           file://default-sysroot.patch \
-           file://sbindir.patch"
+SRC_URI = "git://anonscm.debian.org/collab-maint/ca-certificates.git;protocol=git \
+           file://0002-update-ca-certificates-use-SYSROOT.patch;patch=1 \
+           file://0001-update-ca-certificates-don-t-use-Debianisms-in-run-p.patch;patch=1 \
+           file://update-ca-certificates-support-Toybox.patch;patch=1 \
+           file://default-sysroot.patch;patch=1 \
+           file://sbindir.patch;patch=1"
 
 S = "${WORKDIR}/git"
 
-inherit allarch
+# inherit allarch
+PACKAGE_ARCH = "all"
 
 EXTRA_OEMAKE = "\
     'CERTSDIR=${datadir}/ca-certificates' \
@@ -55,7 +56,7 @@ do_install () {
     } >${D}${sysconfdir}/ca-certificates.conf
 }
 
-do_install_append_class-target () {
+do_install_append_virtclass-target () {
     sed -i -e 's,/etc/,${sysconfdir}/,' \
            -e 's,/usr/share/,${datadir}/,' \
            -e 's,/usr/local,${prefix}/local,' \
@@ -70,15 +71,21 @@ pkg_postinst_${PN} () {
 CONFFILES_${PN} += "${sysconfdir}/ca-certificates.conf"
 
 # Postinsts don't seem to be run for nativesdk packages when populating SDKs.
-CONFFILES_${PN}_append_class-nativesdk = " ${sysconfdir}/ssl/certs/ca-certificates.crt"
-do_install_append_class-nativesdk () {
+CONFFILES_${PN}_append_virtclass-nativesdk = " ${sysconfdir}/ssl/certs/ca-certificates.crt"
+do_install_append_virtclass-nativesdk () {
     SYSROOT="${D}${SDKPATHNATIVE}" ${D}${sbindir}/update-ca-certificates
 }
 
-do_install_append_class-native () {
+do_install_append_virtclass-native () {
     SYSROOT="${D}${base_prefix}" ${D}${sbindir}/update-ca-certificates
+    # older ca-certificates did not run c_rehash, so run manually
+    if [ ! -h /etc/ssl/certs/00673b5b.0 -a -x /usr/bin/c_rehash ]; then
+        cd /etc/ssl/certs
+        /usr/bin/c_rehash .
+    fi
 }
 
 RDEPENDS_${PN} += "openssl"
 
 BBCLASSEXTEND = "native nativesdk"
+NATIVE_INSTALL_WORKS = "1"