sg3-utils: add newer buildable version
[openembedded.git] / recipes / xorg-driver / xf86-video-omapfb_git.bb
1 require xorg-driver-video.inc
2
3 DESCRIPTION = "X.Org X server -- OMAP display driver"
4
5 PR_append = "h"
6
7 SRCREV = "db636c8436265c3d86c5b8e00785e45d55825c80"
8 PV = "0.1.1+${PR}+gitr${SRCREV}"
9 PE = "1"
10
11 SRC_URI = "git://git.pingu.fi/xf86-video-omapfb.git;protocol=http \
12            file://pandora_backlight_dim.patch;patch=1 \
13           "
14
15 S = "${WORKDIR}/git"
16
17 EXTRA_OECONF_armv7a = " --enable-neon "
18 CFLAGS += " -I${STAGING_INCDIR}/xorg "
19
20 # Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay)
21 do_compile_prepend_armv7a () {
22         sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c
23 }
24