8969349dff7c2150779e17de85317534dda3e382
[openembedded.git] / recipes / bluez / bluez4_4.99.bb
1 require bluez4.inc
2
3 PR = "r13"
4
5 SRC_URI += "file://bluetooth.conf \
6             file://sbc_mmx.patch;patch=1 \
7             file://fix-udev-paths.patch;patch=1 \
8             file://obsolete_automake_macros.patch;patch=1 \
9 #            file://network-fix-network-Connect-method-parameters.patch;patch=1 \
10             file://install-test-script.patch;patch=1 \
11 #            file://use-legacy-pygobject-instead-ofgobject-introspection.patch;patch=1 \
12             file://fix_encrypt_collision.patch;patch=1 \
13             file://0001-hciattach_tialt-Implement-texas_change_speed-functio.patch;patch=1 \
14             file://firmware_path.patch;patch=1 \
15             file://enable_socket_api.patch;patch=1 \
16 "
17
18 SRC_URI[md5sum] = "570aa10692ed890aa0a4297b37824912"
19 SRC_URI[sha256sum] = "d884b9aa5d3d9653c076b7646ca14a3e43eb84bccfe8193c49690f802bbd827c"
20
21 RCONFLICTS_${PN} = "bluez5"
22
23 # temporary solution until bug 5176 is properly fixed
24 PROVIDES += "bluez-utils bluez-libs bluez-utils-dbus"
25 RPROVIDES_bluez4 += "bluez-utils bluez-libs bluez-utils-dbus"
26 RPROVIDES_bluez4-dev = "bluez-libs-dev"
27
28 do_install_append() {
29         install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
30         install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
31         install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
32         # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
33         install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
34 }
35
36 RDEPENDS_${PN}-dev = "bluez-hcidump"
37 RDEPENDS_${PN}-testtools += "python python-dbus python-pygobject"
38
39 ALLOW_EMPTY_libasound-module-bluez = "1"
40 PACKAGES =+ "libasound-module-bluez ${PN}-testtools"
41
42 FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
43 FILES_${PN} += "${libdir}/bluetooth/plugins ${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${nonarch_base_libdir}/udev/ ${systemd_unitdir}/ ${datadir}/dbus-1"
44 FILES_${PN}-dev += "\
45   ${libdir}/bluetooth/plugins/*.la \
46   ${libdir}/alsa-lib/*.la \
47 "
48
49 FILES_${PN}-testtools = "${libdir}/bluez4/test/*"
50
51 FILES_${PN}-dbg += "\
52   ${libdir}/bluetooth/plugins/.debug \
53   ${libdir}/*/.debug \
54   ${base_libdir}/*/.debug \
55   */udev/.debug \
56   "
57
58 do_install_append() {
59         # already provided by udev?
60         rm ${D}${base_libdir}/udev/hid2hci
61 }
62
63 SYSTEMD_SERVICE_${PN} = "bluetooth.service"