xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / xfce46.bbclass
1 # xfce46.bbclass
2
3 # Global class to help maintain XFCE 4.6.* packages
4
5 HOMEPAGE = "http://www.xfce.org"
6 LICENSE = "LGPLv2"
7
8 DEPENDS += "startup-notification"
9
10 SECTION ?= "x11/xfce"
11
12 XFCE_VERSION = ${PV}
13
14 SRC_URI = "http://mocha.xfce.org/archive/src/xfce/${PN}/${@'${PV}'[0:3]}/${PN}-${PV}.tar.bz2;name=archive"
15
16 inherit autotools gtk-icon-cache pkgconfig
17
18 AUTOTOOLS_STAGE_PKGCONFIG = "1"
19
20 EXTRA_OECONF += "--with-pluginsdir=${libdir}/xfce4/panel-plugins/"
21
22 # FIXME:  Put icons in their own package too?
23
24 FILES_${PN} += "${datadir}/icons/* ${datadir}/applications/* ${libdir}/xfce4/modules/*.so*"
25 FILES_${PN}-doc += "${datadir}/xfce4/doc"
26
27 FILES_${PN}-dev += "${libdir}/xfce4/*/*.la"
28 FILES_${PN}-dbg += "${libdir}/xfce4/*/.debug"