xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / palmtop.bbclass
1 # this build class sets up qmake variables to
2 #   * build using the Qt Windowing System (QWS)
3 #   * use qt
4 #   * link against supc++ instead of stdc++  
5 #   * use threads, if requested via PALMTOP_USE_MULTITHREADED_QT = "yes"
6 # inherit this class to build programs against libqpe
7 # inherit opie if you want to build programs against libopie2
8 # don't override EXTRA_QMAKEVARS_POST, if you use inherit this class
9
10 inherit qmake
11
12 # special case for DISTRO = sharprom
13 CPP_SUPPORT_LIB = "LIBS-=-lstdc++ LIBS+=-lsupc++"
14 CPP_SUPPORT_LIB_sharprom-compatible = "LIBS+=-lstdc++"
15 EXTRA_QMAKEVARS_POST += "DEFINES+=QWS CONFIG+=qt ${CPP_SUPPORT_LIB}"
16 EXTRA_QMAKEVARS_POST += '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "CONFIG+=thread", "CONFIG-=thread",d)}'
17 EXTRA_QMAKEVARS_POST += "${@["LIBS+=-lqpe ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
18 DEPENDS_prepend = "${@["virtual/libqpe1 uicmoc-native ", ""][(bb.data.getVar('PN', d, 1) == 'libqpe-opie')]}"
19 QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte", d)}'
20 EXTRA_QMAKEVARS_POST += " DEFINES+=OPIE_BINDIR='\"${bindir}\"' DEFINES+=OPIE_LIBDIR='\"${libdir}/opie/lib\"' DEFINES+=OPIE_QTDIR='\"${libdir}/opie\"' "
21
22 PACKAGES = "${PN}-dbg ${PN}-dev ${PN} ${PN}-doc ${PN}-locale"
23 FILES_${PN} += " ${palmtopdir} "
24 FILES_${PN}-dbg += " ${palmtopdir}/lib/.debug \
25                      ${palmtopdir}/bin/.debug \
26                      ${palmtopdir}/plugins/*/.debug "