xf86-video-omapfb: pandora: handle cycle/forcer events better
[openembedded.git] / classes / openmoko-base.bbclass
1 HOMEPAGE = "http://www.openmoko.org"
2 LICENSE ?= "GPL"
3 OPENMOKO_RELEASE ?= "OM-2007.2"
4 OPENMOKO_MIRROR ?= "svn://svn.openmoko.org/trunk"
5
6 def openmoko_base_get_subdir(d):
7     openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
8     if section == 'base' or section == 'libs': return ""
9     elif section in 'apps tools pim'.split(): return "applications"
10     elif section == "panel-plugin": return "panel-plugins"
11     elif section == "inputmethods": return "inputmethods"
12     else: return section
13
14 SUBDIR = "${@openmoko_base_get_subdir(d)}"
15
16 SRC_URI := "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/${SUBDIR};module=${PN};proto=http"
17 S = "${WORKDIR}/${PN}"
18
19 FILES_${PN} += "${datadir}/icons"