sg3-utils: add newer buildable version
[openembedded.git] / classes / gpe.bbclass
1 DEPENDS_prepend = "coreutils-native virtual/libintl intltool-native "
2 GPE_TARBALL_SUFFIX ?= "gz"
3 SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.${GPE_TARBALL_SUFFIX}"
4 FILES_${PN} += "${datadir}/gpe ${datadir}/application-registry"
5 SECTION ?= "gpe"
6
7 inherit gettext
8
9 gpe_do_compile() {
10         oe_runmake PREFIX=${prefix}
11 }
12
13 gpe_do_install() {
14         oe_runmake PREFIX=${prefix} DESTDIR=${D} install
15 }
16
17 EXPORT_FUNCTIONS do_compile do_install