util-linux-ng: fix swaponoff
[openembedded.git] / recipes / preboot / initramfs-preboot-image.bb
1 #initramfs image which mounts the rootfilesystem and kexecs a kernel from there
2 PR = "r1"
3
4 ONLINE_PACKAGE_MANAGEMENT = "none"
5 IMAGE_FSTYPES = "cpio.gz"
6
7 export IMAGE_BASENAME = "initramfs-preboot-image"
8
9 IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
10
11 # avoid circular dependencies
12 EXTRA_IMAGEDEPENDS = ""
13
14 IMAGE_INSTALL = " \
15         task-boot \
16         util-linux-ng-mount util-linux-ng-umount \
17         dropbear \
18         fontconfig \
19         ttf-freefonts \
20         eina \
21         evas \
22         edje \
23         efreet \
24         eet \
25         edbus \
26         elementary \
27         elementary-themes \
28         elementary-tests \
29         fbset \
30         fbset-init \
31     msmcommd \
32 #       lvm2 \
33 #       preboot \
34         "
35
36 IMAGE_LINGUAS = ""
37
38 inherit image
39
40 preboot_palmpre_rootfs_postprocess() {
41         # copy all our files to the rootfs
42         dirs=`find ${FILESDIR} -type d -printf "%P\n" | grep -v "^.$" | grep -v ".git"`
43         for dir in $dirs; do
44                 mkdir -p ${IMAGE_ROOTFS}/$dir
45         done
46         files=`find ${FILESDIR} -type f -printf "%P\n" | grep -v ".git"`
47         for file in $files; do
48                 cp -f ${FILESDIR}/$file ${IMAGE_ROOTFS}/$file
49         done
50
51         curdir=$PWD
52         cd ${IMAGE_ROOTFS}
53
54         # install our usbnet initscript
55         chmod +x etc/init.d/usbnet
56 #       ln -sf ../init.d/usbnet ${IMAGE_ROOTFS}/etc/rcS.d/S15usbnet
57
58         # miniboot sequence (just for debugging)
59         rm ${IMAGE_ROOTFS}/sbin/init
60         chmod +x ${IMAGE_ROOTFS}/etc/miniboot.sh 
61         ln -sf /etc/miniboot.sh ${IMAGE_ROOTFS}/init
62         ln -sf ../etc/miniboot.sh ${IMAGE_ROOTFS}/sbin/init
63
64         cd $curdir
65 }
66
67 ROOTFS_POSTPROCESS_COMMAND_palmpre += " preboot_palmpre_rootfs_postprocess"
68
69