util-linux-ng: fix swaponoff
[openembedded.git] / recipes / mozilla / rhino_1.7r1.bb
1 DESCRIPTION = "Lexical analyzer generator for Java"
2
3 LICENSE = "GPL MPL"
4
5 DEPENDS = "fastjar-native"
6
7 inherit java-library
8
9 SRC_URI = "\
10         ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R1.zip \
11         file://rhino \
12         file://rhino-jsc \
13         "
14
15 S = "${WORKDIR}/rhino1_7R1"
16
17 PACKAGES = "${JPN} rhino"
18
19 FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
20 RDEPENDS_${PN} = "java2-runtime ${JPN}"
21
22 do_compile() {
23   mkdir -p build
24
25         # Compatibility fix for jamvm which has non-genericised
26   # java.lang classes. :(
27         bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
28
29   javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"`
30
31         mkdir -p build/org/mozilla/javascript/resources
32         cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
33
34   fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
35 }
36
37 do_install_append() {
38         install -d ${D}${bindir}
39
40         install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
41         install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
42 }