util-linux-ng: fix swaponoff
[openembedded.git] / recipes / less / less_458.bb
1 SUMMARY = "Text file viewer similar to more"
2 DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3 based program for viewing text files and the output from other \
4 programs. Less offers many features beyond those that more does."
5 HOMEPAGE = "http://www.greenwoodsoftware.com/"
6 SECTION = "console/utils"
7
8 # (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
9 # less is a 2-clause BSD-like permissive license
10 LICENSE = "GPLv3+ less"
11 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
12                     file://LICENSE;md5=1237c0f825bb36122b0b2b486ffbe6be"
13 DEPENDS = "ncurses"
14 PR = "r0"
15
16 SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz"
17
18 SRC_URI[md5sum] = "935b38aa2e73c888c210dedf8fd94f49"
19 SRC_URI[sha256sum] = "e536c7819ede54b3d487f0ffc4c14b3620bed83734d92a81e89f62346db0fcac"
20
21
22 inherit autotools update-alternatives
23
24 do_install () {
25         oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
26         mv ${D}${bindir}/less ${D}${bindir}/less.${PN}
27 }
28
29 ALTERNATIVE_NAME = "less"
30 ALTERNATIVE_PATH = "less.${PN}"
31 ALTERNATIVE_PRIORITY = "100"