util-linux-ng: fix swaponoff
[openembedded.git] / recipes / classpath / classpath-initial_0.93.bb
1 # No later version of Classpath may be used because this is the latest that can be compiled
2 # by jikes!
3
4 require classpath-native.inc
5
6 DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
7
8 PR = "r6"
9
10 DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
11
12 SRC_URI += "\
13         file://autotools.patch;patch=1 \
14         file://miscompilation-0.93.patch;patch=1 \
15         "
16
17 EXTRA_OECONF = "\
18   --with-jikes=jikes \
19   --with-fastjar=fastjar \
20   --with-glibj \
21   --disable-Werror \
22   --disable-local-sockets \
23   --disable-alsa \
24   --disable-gconf-peer \
25   --disable-gtk-peer \
26   --disable-plugin \
27   --disable-dssi \
28   --disable-examples \
29   --disable-tools \
30   --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \
31   --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \
32   --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \
33   "