pandora-version: add a changelog
[openpandora.oe.git] / recipes / pandora-system / pandora-version.bb
index 0fd3db7..918cc44 100644 (file)
@@ -1,6 +1,12 @@
 DESCRIPTION = "Installs /etc/op-version file."
 LICENSE = "Public Domain"
-PR = "r35"
+
+# a reminder: update the changelog!
+PR = "r36"
+
+SRC_URI = " \
+  file://changelog \
+"
 
 do_install() {
   OLD_PWD=$PWD
@@ -18,8 +24,11 @@ do_install() {
   echo "Display Ver: SuperZaxxon 1.75${updv}" >> ${opvf}
   echo "Image Builder: ${LOGNAME}@`cat /etc/hostname`" >> ${opvf}
   echo "Time Stamp: `date -R`" >> ${opvf}
+
+  install -d ${D}${prefix}/pandora/
+  install -m 0644 ${WORKDIR}/changelog ${D}${prefix}/pandora/
 }
 
-FILES_${PN} += "${sysconfdir}/op-version"
+FILES_${PN} += "${sysconfdir}/op-version ${prefix}/pandora"
 
 COMPATIBLE_MACHINE = "omap3-pandora"