gpe-helpviewer: replaced direct directory names use with variables. Closes 2451.
authorSergey Lapin <slapinid@gmail.com>
Sat, 17 May 2008 22:49:19 +0000 (22:49 +0000)
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>
Sat, 17 May 2008 22:49:19 +0000 (22:49 +0000)
* commit from Laibsch.

packages/gpe-helpviewer/gpe-helpviewer_1.0.bb

index eb9c9ba..dcd6486 100644 (file)
@@ -1,13 +1,10 @@
-PR = "r2"
-
 DESCRIPTION = "A helpviewer based on gtk+webcore"
 LICENSE = "GPL"
-
-SRC_URI = "http://stag.mind.be/gpe-helpviewer-${PV}.tar.bz2"
-
 DEPENDS = "osb-nrcit"
 RDEPENDS = "gpe-helpviewer-doc"
+PR = "r2"
 
+SRC_URI = "http://stag.mind.be/gpe-helpviewer-${PV}.tar.bz2"
 
 S = "${WORKDIR}/gpe-helpviewer"
 
@@ -16,23 +13,23 @@ inherit autotools
 do_install() {
                install -d ${D}${docdir}/gpe
                install -m 0644 ${S}/gpe-helpviewer.html  ${D}${docdir}/gpe/
-               install -d ${D}/usr/share/applications
-               install -m 0644 ${S}/gpe-helpviewer.desktop ${D}/usr/share/applications/gpe-helpviewer.desktop
-               install -d ${D}/usr/share/pixmaps
-               install -m 0644 ${S}/gpe-help.png ${D}/usr/share/pixmaps/gpe-help.png
+               install -d ${D}${datadir}/applications
+               install -m 0644 ${S}/gpe-helpviewer.desktop ${D}${datadir}/applications/gpe-helpviewer.desktop
+               install -d ${D}${datadir}/pixmaps
+               install -m 0644 ${S}/gpe-help.png ${D}${datadir}/pixmaps/gpe-help.png
                autotools_do_install
 }
 
 pkg_postinst_${PN}-doc () {
         #!/bin/sh
        if [ "x$D" != "x" ]; then
-        if [ -e /etc/gpe/gpe-help.conf ]; then
-                echo gpe-helpviewer = /usr/share/doc/gpe/gpe-helpviewer.html >> /etc/gpe/gpe-help.conf
+        if [ -e ${sysconfdir}/gpe/gpe-help.conf ]; then
+                echo gpe-helpviewer = ${docdir}/gpe/gpe-helpviewer.html >> ${sysconfdir}/gpe/gpe-help.conf
         else
-                 echo [Help] >> /etc/gpe/gpe-help.conf
-                 echo gpe-helpviewer = /usr/share/doc/gpe/gpe-helpviewer.html >> /etc/gpe/gpe-help.conf
+                 echo [Help] >> ${sysconfdir}/gpe/gpe-help.conf
+                 echo gpe-helpviewer = ${docdir}/gpe/gpe-helpviewer.html >> ${sysconfdir}/gpe/gpe-help.conf
         fi
-        if [ -x /usr/bin/gpe-helpindex ]; then
+        if [ -x ${bindir}/gpe-helpindex ]; then
                 echo generating help-index
                 gpe-helpindex
         else
@@ -44,11 +41,11 @@ pkg_postinst_${PN}-doc () {
 pkg_postrm_${PN}-doc () {
         #!/bin/sh
        if [ "x$D" != "x" ]; then
-        if [ -e /etc/gpe/gpe-help.conf ]; then
-                sed '/^\<gpe-helpviewer\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
-                mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
+        if [ -e ${sysconfdir}/gpe/gpe-help.conf ]; then
+                sed '/^\<gpe-helpviewer\>/d' ${sysconfdir}/gpe/gpe-help.conf > /tmp/gpe-help.conf
+                mv /tmp/gpe-help.conf ${sysconfdir}/gpe/gpe-help.conf
         fi
-        if [ -x /usr/bin/gpe-helpindex ]; then
+        if [ -x ${bindir}/gpe-helpindex ]; then
                 echo generating help-index
                 gpe-helpindex
         else