pth: use LDFLAGS (fixes QA error)
authorJeremy Lainé <jeremy.laine@m4x.org>
Mon, 6 Apr 2009 12:16:20 +0000 (12:16 +0000)
committerJeremy Lainé <jeremy.laine@m4x.org>
Mon, 6 Apr 2009 12:16:20 +0000 (12:16 +0000)
recipes/pth/files/ldflags.patch [new file with mode: 0644]
recipes/pth/pth_2.0.2.bb

diff --git a/recipes/pth/files/ldflags.patch b/recipes/pth/files/ldflags.patch
new file mode 100644 (file)
index 0000000..9537ca8
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urN pth-2.0.2.orig/Makefile.in pth-2.0.2/Makefile.in
+--- pth-2.0.2.orig/Makefile.in 2004-07-13 10:48:10.000000000 +0000
++++ pth-2.0.2/Makefile.in      2009-04-06 12:12:37.000000000 +0000
+@@ -168,10 +168,10 @@
+ #   build the static and possibly shared libraries
+ libpth.la: $(LOBJS)
+-      $(LIBTOOL) --mode=link --quiet $(CC) -o libpth.la $(LOBJS) \
++      $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpth.la $(LOBJS) \
+       -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ libpthread.la: pthread.lo $(LOBJS)
+-      $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
++      $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
+       -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ #   build the manual pages
index 81b8a71..2583e03 100644 (file)
@@ -2,10 +2,11 @@ DESCRIPTION = "GNU Portable Threads"
 SECTION = "libs"
 PRIORITY = "optional"
 LICENSE = "GPL LGPL FDL"
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
           file://m4-warning.patch;patch=1 \
+          file://ldflags.patch;patch=1 \
          "
 
 PARALLEL_MAKE=""