scummvm: fix the fact that none of the engines were builtin(so scummvm was useless...
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Thu, 22 Jan 2009 14:55:12 +0000 (15:55 +0100)
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Thu, 22 Jan 2009 18:06:21 +0000 (19:06 +0100)
*took the lacking scummvm/files/openmoko/openmoko-scummvm from the openmoko wiki
*no-strip.patch for the 0.12.0 version : if you let the Makefile strip,openembedded skip stripping and so it can't copy the unstripped binaries before stripping...and so it creates an empty -dbg package
*must check the stripping for the others versions
*explanation of the main fix: most of the recipes added something like this:
DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-DUSE_MAD -DUSE_MPEG2', d)}"
this did override the DEFINES...and so defines such as -DENABLE_ENGINENAME=STATIC_PLUGIN were no longer defined...and so none of the engines were built...
I removed it and remplaced it by
${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \
${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_LIBDIR}/..', d)} \
I've also tested it with ENTREPRISE_DISTRO = "1" in my local.conf here are what I checked:
**the configure log:
Checking for MAD... no
Checking for libmpeg2 >= 0.3.2... no
**the run.do_configure.21902 shell script:
--disable-mpeg2 twice in oe_runconf and in do_configure ..no other matches for mpeg
same thing for --disable-mad
**the about menu inside scummvm says vorbis zlib in the "features compiled in" section
and there were no mention of mad,mp3 or mpeg2

*bump all PR

packages/scummvm/files/no-strip.patch [new file with mode: 0644]
packages/scummvm/files/openmoko/openmoko-scummvm [new file with mode: 0644]
packages/scummvm/scummvm-qpe_0.6.1b.bb
packages/scummvm/scummvm.inc
packages/scummvm/scummvm_0.12.0.bb
packages/scummvm/scummvm_0.6.0.bb
packages/scummvm/scummvm_0.6.1b.bb
packages/scummvm/scummvm_0.9.0.bb
packages/scummvm/scummvm_0.9.1.bb

diff --git a/packages/scummvm/files/no-strip.patch b/packages/scummvm/files/no-strip.patch
new file mode 100644 (file)
index 0000000..4df1283
--- /dev/null
@@ -0,0 +1,22 @@
+Index: scummvm-0.12.0/ports.mk
+===================================================================
+--- scummvm-0.12.0.orig/ports.mk
++++ scummvm-0.12.0/ports.mk
+@@ -10,7 +10,7 @@
+ #
+ install: all
+       $(INSTALL) -d "$(DESTDIR)$(BINDIR)"
+-      $(INSTALL) -c -s -m 755 "$(srcdir)/scummvm$(EXEEXT)" "$(DESTDIR)$(BINDIR)/scummvm$(EXEEXT)"
++      $(INSTALL) -c -m 755 "$(srcdir)/scummvm$(EXEEXT)" "$(DESTDIR)$(BINDIR)/scummvm$(EXEEXT)"
+       $(INSTALL) -d "$(DESTDIR)$(MANDIR)/man6/"
+       $(INSTALL) -c -m 644 "$(srcdir)/dists/scummvm.6" "$(DESTDIR)$(MANDIR)/man6/scummvm.6"
+       $(INSTALL) -d "$(DESTDIR)$(PREFIX)/share/pixmaps/"
+@@ -21,7 +21,7 @@ install: all
+       $(INSTALL) -c -m 644 $(DIST_FILES_THEMES) $(DIST_FILES_ENGINEDATA) "$(DESTDIR)$(DATADIR)/scummvm/"
+ ifdef DYNAMIC_MODULES
+       $(INSTALL) -d "$(DESTDIR)$(LIBDIR)/scummvm/"
+-      $(INSTALL) -c -s -m 644 $(DIST_FILES_PLUGINS) "$(DESTDIR)$(LIBDIR)/scummvm/"
++      $(INSTALL) -c -m 644 $(DIST_FILES_PLUGINS) "$(DESTDIR)$(LIBDIR)/scummvm/"
+ endif
+ uninstall:
diff --git a/packages/scummvm/files/openmoko/openmoko-scummvm b/packages/scummvm/files/openmoko/openmoko-scummvm
new file mode 100644 (file)
index 0000000..58eb2bb
--- /dev/null
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+# Save current AUX Key mapping
+SAVE_KEY="$(xmodmap -pke | grep 'keycode 177')"
+
+# Map AUX Key to F5
+xmodmap -e "keycode 177 = F5"
+
+# Turn LCD feft
+xrandr -o left
+
+# Start the scummvm in fullscreen mode
+scummvm --fullscreen --themepath=/usr/share/scummvm/
+
+# Turn LCD normal
+xrandr -o normal
+
+# Restore the AUX Key mapping
+xmodmap -e "$SAVE_KEY"
index b66d586..7618e09 100644 (file)
@@ -1,11 +1,5 @@
 require scummvm.inc
 
-DEPENDS = "libsdl-qpe libmad tremor libogg zlib mpeg2dec"
+DEPENDS = "libsdl-qpe tremor libogg zlib ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad mpeg2dec', d)}"
 
 S = "${WORKDIR}/scummvm-${PV}/"
-
-do_compile() {
-       oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
-                   DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DQTOPIA -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
-}
-
index e12341e..6be99ca 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.scummvm.org"
 SECTION = "games"
 PRIORITY = "optional"
 LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2"
 
@@ -16,8 +16,9 @@ EXTRA_OECONF = "--host=${HOST_SYS} \
                --prefix=${prefix} \
                --with-ogg-prefix=${STAGING_LIBDIR}/.. \
                --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
-               --with-mpeg2-prefix=${STAGING_LIBDIR}/.. \
-               --with-mad-prefix=${STAGING_LIBDIR}/.. "
+               ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \
+               ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_LIBDIR}/..', d)} \
+               "
 
 EXTRA_OEMAKE = "MANDIR=${mandir}"
 
index 8a45f0e..630db67 100644 (file)
@@ -5,7 +5,8 @@ CCACHE = ""
 DEPENDS = "virtual/libsdl libvorbis libogg zlib \
            ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad mpeg2dec', d)}"
 
-SRC_URI += " file://scummvm.desktop "
+SRC_URI += " file://scummvm.desktop \
+       file://no-strip.patch;patch=1"
 
 SRC_URI_append_openmoko = " file://openmoko-scummvm "
 
@@ -13,18 +14,10 @@ SRC_URI_append_openmoko = " file://openmoko-scummvm "
 SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
 
 EXTRA_OECONF += " \
-               --disable-scumm-7-8 \
+               --disable-scumm-7-8 \ 
                --disable-he \
                "
 
-do_compile() {
-       oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" \
-                   CXXFLAGS="${CXXFLAGS}" \
-                   LDFLAGS="${LDFLAGS} ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-lmpeg2', d)}" \
-                   DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-DUSE_MAD -DUSE_MPEG2', d)}"
-}
-
-
 do_install_append() {
        if [ -f ${WORKDIR}/openmoko-scummvm ]; then
                install -d ${D}${bindir}
index 9c8477d..6ff76e6 100644 (file)
@@ -9,6 +9,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2 \
                        file://sword1.patch;patch=1 \
                        file://tremor.patch;patch=1 \
                        file://mouse.patch;patch=1 "
+PR="r1"
 
 inherit autotools
 
@@ -19,18 +20,13 @@ EXTRA_OECONF = "--host=${HOST_SYS} \
                --disable-alsa \
                --with-ogg-prefix=${STAGING_LIBDIR}/.. \
                --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
-               --with-mpeg2-prefix=${STAGING_LIBDIR}/.. \
-               --with-mad-prefix=${STAGING_BINDIR_CROSS}/.. "
-
+               ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \              
+               ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_BINDIR_CROSS}/..', d)} \
+               "
 do_configure() {
        ./configure ${EXTRA_OECONF}
 }
 
-do_compile() {
-       oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
-                   DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DQTOPIA -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
-}
-
 do_install() {
        install -d ${D}${bindir}
        install -m 0755 scummvm ${D}${bindir}/scummvm
index 638a39e..7c85caf 100644 (file)
@@ -7,9 +7,3 @@ SRC_URI += " file://mouse.patch;patch=1 \
             file://tail-obselete-fix.patch;patch=1 \
             file://tremor.patch;patch=1"
 
-do_compile() {
-       oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS} -lmpeg2" \
-                   DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT  -DUSE_MAD -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2"
-}
-
-
index 01ade38..f521e13 100644 (file)
@@ -7,12 +7,3 @@ EXTRA_OECONF += "--enable-lure \
                 --enable-agi \
                 --enable-cine \
                 "
-
-do_compile() {
-       oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" \
-                   CXXFLAGS="${CXXFLAGS}" \
-                   LDFLAGS="${LDFLAGS} ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-lmpeg2', d)}" \
-                   DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-DUSE_MAD -DUSE_MPEG2', d}"
-}
-
-
index d10f540..b64ac1d 100644 (file)
@@ -15,14 +15,6 @@ EXTRA_OECONF += "--enable-lure \
                 --enable-cine \
                 "
 
-do_compile() {
-       oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}" \
-                   CXXFLAGS="${CXXFLAGS}" \
-                   LDFLAGS="${LDFLAGS} ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-lmpeg2', d)}" \
-                   DEFINES="-DUNIX -DSCUMM_NEED_ALIGNMENT -DUSE_VORBIS -DUSE_ZLIB -DUSE_MPEG2 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '-DUSE_MAD -DUSE_MPEG2', d)}"
-}
-
-
 do_install_append() {
        if [ -f ${WORKDIR}/openmoko-scummvm ]; then
                install -d ${D}${bindir}