git: remove version specifics from generic inc
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 8 Feb 2010 11:14:31 +0000 (11:14 +0000)
committerKhem Raj <raj.khem@gmail.com>
Wed, 10 Feb 2010 20:20:14 +0000 (12:20 -0800)
Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/git/git-native_1.6.0.4.bb
recipes/git/git.inc
recipes/git/git_1.6.0.4.bb

index 71b111b..c17ce6e 100644 (file)
@@ -2,3 +2,4 @@ require git.inc
 inherit native
 DEPENDS = "openssl-native curl-native zlib-native expat-native"
 PR = "r4"
+SRC_URI += "file://autotools.patch;patch=1"
index fb88fd4..644e159 100644 (file)
@@ -2,9 +2,8 @@ DESCRIPTION = "The git revision control system used by the Linux kernel develope
 SECTION = "console/utils"
 LICENSE = "GPL"
 
-SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2 \
-           file://autotools.patch;patch=1 \
-          "
+SRC_URI = "http://www.kernel.org/pub/software/scm/git/git-${PV}.tar.bz2"
+
 S = "${WORKDIR}/git-${PV}"
 
 inherit autotools
index e839ab9..c37e3d0 100644 (file)
@@ -1,6 +1,7 @@
 require git.inc
 
-SRC_URI += "file://snprintf-returns-bogus.patch;patch=1"
+SRC_URI += "file://autotools.patch;patch=1 \
+            file://snprintf-returns-bogus.patch;patch=1"
 
 DEPENDS = "openssl curl zlib expat"
 RDEPENDS = "perl perl-module-file-path cpio findutils sed"