libgles-omap3: use udev rule to change permissions on bccat and v4l nodes
authorKoen Kooi <k-kooi@ti.com>
Fri, 26 Mar 2010 12:31:56 +0000 (13:31 +0100)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 22 Jan 2011 22:14:30 +0000 (00:14 +0200)
recipes/powervr-drivers/libgles-omap3.inc
recipes/powervr-drivers/libgles-omap3/99-bufferclass.rules [new file with mode: 0644]
recipes/powervr-drivers/libgles-omap3/rc.pvr
recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
recipes/powervr-drivers/libgles-omap3_3.01.00.05.bb

index 2adcb8b..3a6d243 100644 (file)
@@ -24,7 +24,8 @@ SRC_URI = "file://OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin \
                   file://cputype \
                   file://rc.pvr \
                   file://sample.desktop \
-                 "
+                  file://99-bufferclass.rules  \
+"
 
 S = "${WORKDIR}/OMAP35x_Graphics_SDK_${SGXPV}"
 
@@ -197,6 +198,10 @@ do_install () {
        # Delete objects and linker scripts hidden between the headers
        find ${D} -name "*.o" -delete
        find ${D} -name "*.o.cmd" -delete
+
+       install -d ${D}${sysconfdir}/udev/rules.d
+       install -m 0644 ${WORKDIR}/99-bufferclass.rules ${D}${sysconfdir}/udev/rules.d/
+
 }
 
 PACKAGES =+ "${PN}-rawdemos \
diff --git a/recipes/powervr-drivers/libgles-omap3/99-bufferclass.rules b/recipes/powervr-drivers/libgles-omap3/99-bufferclass.rules
new file mode 100644 (file)
index 0000000..780423b
--- /dev/null
@@ -0,0 +1,7 @@
+# Give everyone access to bufferclass nodes and make a compatibility symlink for the first one
+SUBSYSTEM=="bccat", MODE="0666"
+KERNEL=="bccat0", SYMLINK+="bc_cat", MODE="0666"
+
+# Give everyone access to v4l nodes
+SUBSYSTEM=="video4linux", MODE="0666"
+
index 4fbda01..b84225e 100755 (executable)
@@ -33,7 +33,6 @@ fbset -vyres $(expr $YRES \* 3)
 if [ $CPUTYPE = "OMAP3530" ]; then
        echo Starting PVR
        insmod $(busybox find /lib/modules/$(uname -r) -name "pvrsrvkm.ko")
-       #modprobe bc_example
        modprobe omaplfb
        modprobe bufferclass_ti
 
@@ -47,13 +46,6 @@ if [ $CPUTYPE = "OMAP3530" ]; then
        mknod /dev/pvrsrvkm c $pvr_maj 0 
        chmod 666 /dev/pvrsrvkm
 
-       if [ -e /dev/bc_cat ] ; then
-               rm -f /dev/bc_cat
-       fi
-
-       mknod /dev/bc_cat c $bc_maj 0
-       chmod 666 /dev/bc_cat
-
        touch /etc/powervr-esrev
 
        SAVED_ESREVISION="$(cat /etc/powervr-esrev)"
index 725e8bb..129db3f 100644 (file)
@@ -2,7 +2,7 @@ BINLOCATION = "${S}/gfx_rel_es3.x"
 
 require libgles-omap3.inc
 
-PR = "r6"
+PR = "r7"
 
 # download required binary distribution from:
 # http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
index daac041..3264a08 100644 (file)
@@ -1,6 +1,6 @@
 DEFAULT_PREFERENCE = "-1"
 
-PR = "r1"
+PR = "r2"
 
 BINLOCATION = "${S}/gfx_rel_es3.x"