gnome-games: fix previous bad patch -I/SDL error
authorRoger Monk <r-monk@ti.com>
Mon, 24 Aug 2009 21:00:51 +0000 (22:00 +0100)
committerKoen Kooi <koen@openembedded.org>
Tue, 25 Aug 2009 09:47:05 +0000 (11:47 +0200)
recipes/gnome/gnome-games_2.24.0.bb

index cc795e1..6449c82 100644 (file)
@@ -24,7 +24,10 @@ do_configure_prepend() {
 
 do_configure_append() {
        for i in $(find ${S} -name "Makefile") ; do
-               sed -i -e s:'I/usr/include'::g -e s:'-I /usr/include -I /usr/local/include'::g $i
+               sed -i \
+                       -e s:'-I/usr/include/SDL':'-I${STAGING_INCDIR}/SDL':g \
+                       -e s:'-I/usr/local/include/SDL':'-I${STAGING_INCDIR}/SDL':g \
+                       $i
        done    
 }