shr phone applications: new recipes
authorMartin Jansa <Martin.Jansa@gmail.com>
Sun, 15 Nov 2009 18:29:48 +0000 (19:29 +0100)
committerKlaus Kurzmann <mok@fluxnetz.de>
Sun, 15 Nov 2009 18:56:34 +0000 (19:56 +0100)
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
12 files changed:
recipes/shr/initscripts-shr_0.0.1.bb [new file with mode: 0644]
recipes/shr/libmodulo_git.bb [new file with mode: 0644]
recipes/shr/libphone-ui-shr_git.bb [new file with mode: 0644]
recipes/shr/libphone-ui_git.bb [new file with mode: 0644]
recipes/shr/ologicd_git.bb [new file with mode: 0644]
recipes/shr/phonefsod_git.bb [new file with mode: 0644]
recipes/shr/phoneui-apps_git.bb [new file with mode: 0644]
recipes/shr/phoneuid_git.bb [new file with mode: 0644]
recipes/shr/shr-config_git.bb [new file with mode: 0644]
recipes/shr/shr-launcher_svn.bb [new file with mode: 0644]
recipes/shr/shr-settings_git.bb [new file with mode: 0644]
recipes/shr/shr-specs_git.bb [new file with mode: 0644]

diff --git a/recipes/shr/initscripts-shr_0.0.1.bb b/recipes/shr/initscripts-shr_0.0.1.bb
new file mode 100644 (file)
index 0000000..23fa05f
--- /dev/null
@@ -0,0 +1,107 @@
+DESCRIPTION = "SHR init scripts"
+SECTION = "base"
+PRIORITY = "required"
+DEPENDS = ""
+RDEPENDS = ""
+LICENSE = "GPL"
+PV = "0.0.1"
+PR = "r11"
+
+RPROVIDES_${PN} = "initscripts"
+RCONFLICTS_${PN} = "initscripts"
+RREPLACES_${PN} = "initscripts"
+
+SRC_URI = "file://alignment.sh \
+          file://bootmisc.sh \
+          file://checkroot.sh \
+          file://finish.sh \
+          file://functions \
+          file://g_ether.sh \
+          file://hostname.sh \
+          file://mountall.sh \
+          file://mountdevsubfs.sh \
+          file://mountkernfs.sh \
+          file://mountnfs.sh \
+          file://populate-volatile.sh \
+          file://devpts \
+          file://volatiles \
+          file://halt \
+          file://reboot \
+          file://rmnologin \
+          file://save-rtc.sh \
+          file://sendsigs \
+          file://umountfs \
+          file://umountnfs.sh \
+          "
+
+inherit base
+
+do_install () {
+#
+# Create directories and install device independent scripts
+#
+       install -d ${D}${sysconfdir}/init.d
+       install -d ${D}${sysconfdir}/rcS.d
+       install -d ${D}${sysconfdir}/rc0.d
+       install -d ${D}${sysconfdir}/rc1.d
+       install -d ${D}${sysconfdir}/rc2.d
+       install -d ${D}${sysconfdir}/rc3.d
+       install -d ${D}${sysconfdir}/rc4.d
+       install -d ${D}${sysconfdir}/rc5.d
+       install -d ${D}${sysconfdir}/rc6.d
+       install -d ${D}${sysconfdir}/default
+       install -d ${D}${sysconfdir}/default/volatiles
+
+       install -m 0755 ${WORKDIR}/alignment.sh         ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/bootmisc.sh          ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/checkroot.sh         ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/finish.sh            ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/functions            ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/g_ether.sh           ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/hostname.sh          ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/mountall.sh          ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/mountnfs.sh          ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/mountdevsubfs.sh     ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/mountkernfs.sh       ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/populate-volatile.sh ${D}${sysconfdir}/init.d
+
+       install -m 0644 ${WORKDIR}/devpts               ${D}${sysconfdir}/default/devpts
+       install -m 0644 ${WORKDIR}/volatiles            ${D}${sysconfdir}/default/volatiles/00_core
+
+       install -m 0755 ${WORKDIR}/halt                 ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/reboot               ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/rmnologin            ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/save-rtc.sh          ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/sendsigs             ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/umountfs             ${D}${sysconfdir}/init.d
+       install -m 0755 ${WORKDIR}/umountnfs.sh         ${D}${sysconfdir}/init.d
+
+#
+# Create runlevel links
+#
+       ln -sf          ../init.d/mountkernfs.sh        ${D}${sysconfdir}/rcS.d/S01mountkernfs.sh
+       ln -sf          ../init.d/g_ether.sh            ${D}${sysconfdir}/rcS.d/S02g_ether.sh
+       ln -sf          ../init.d/hostname.sh           ${D}${sysconfdir}/rcS.d/S02hostname.sh
+       ln -sf          ../init.d/checkroot.sh          ${D}${sysconfdir}/rcS.d/S02checkroot.sh
+       ln -sf          ../init.d/mountdevsubfs.sh      ${D}${sysconfdir}/rcS.d/S04mountdevsubfs.sh
+       ln -sf          ../init.d/alignment.sh          ${D}${sysconfdir}/rcS.d/S06alignment.sh
+       ln -sf          ../init.d/mountall.sh           ${D}${sysconfdir}/rcS.d/S35mountall.sh
+       ln -sf          ../init.d/populate-volatile.sh  ${D}${sysconfdir}/rcS.d/S37populate-volatile.sh
+       ln -sf          ../init.d/mountnfs.sh           ${D}${sysconfdir}/rcS.d/S45mountnfs.sh
+       ln -sf          ../init.d/bootmisc.sh           ${D}${sysconfdir}/rcS.d/S55bootmisc.sh
+       ln -sf          ../init.d/finish.sh             ${D}${sysconfdir}/rcS.d/S99finish.sh
+
+       ln -sf          ../init.d/rmnologin             ${D}${sysconfdir}/rc5.d/S99rmnologin
+
+       ln -sf          ../init.d/sendsigs              ${D}${sysconfdir}/rc0.d/S20sendsigs
+       ln -sf          ../init.d/save-rtc.sh           ${D}${sysconfdir}/rc0.d/S25save-rtc.sh
+       ln -sf          ../init.d/umountnfs.sh          ${D}${sysconfdir}/rc6.d/S31umountnfs.sh
+       ln -sf          ../init.d/umountfs              ${D}${sysconfdir}/rc0.d/S40umountfs
+       ln -sf          ../init.d/halt                  ${D}${sysconfdir}/rc0.d/S90halt
+
+       ln -sf          ../init.d/sendsigs              ${D}${sysconfdir}/rc6.d/S20sendsigs
+       ln -sf          ../init.d/save-rtc.sh           ${D}${sysconfdir}/rc6.d/S25save-rtc.sh
+       ln -sf          ../init.d/umountnfs.sh          ${D}${sysconfdir}/rc6.d/S31umountnfs.sh
+       ln -sf          ../init.d/umountfs              ${D}${sysconfdir}/rc6.d/S40umountfs
+       ln -sf          ../init.d/reboot                ${D}${sysconfdir}/rc6.d/S90reboot
+}
diff --git a/recipes/shr/libmodulo_git.bb b/recipes/shr/libmodulo_git.bb
new file mode 100644 (file)
index 0000000..dcf204c
--- /dev/null
@@ -0,0 +1,13 @@
+DESCRIPTION = "Modulo is a lightweight component container that supports Inversion Of Control, also commonly called Dependency Injection"
+SECTION = "libs"
+PV = "0.0.1+gitr${SRCPV}"
+PR = "r1"
+
+inherit autotools autotools_stage pkgconfig vala girepository
+
+DEPENDS = "glib-2.0 dbus-glib libxml2 libgee"
+
+SRC_URI = "git://git.shr-project.org/repo/libmodulo.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+LEAD_SONAME = "libmodulo.so.0"
diff --git a/recipes/shr/libphone-ui-shr_git.bb b/recipes/shr/libphone-ui-shr_git.bb
new file mode 100644 (file)
index 0000000..240c7f2
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "SHR default module for the Phone UI daemon"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libphone-ui etk evas ecore edje edje-native elementary"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "git://shr.bearstech.com/repo/libphone-ui-shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools autotools_stage
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+
+do_configure_prepend() {
+        autopoint --force
+}
+
+FILES_${PN} += "${libdir}/phoneui/modules/*"
+FILES_${PN}-dbg += "${libdir}/phoneui/modules/.debug"
\ No newline at end of file
diff --git a/recipes/shr/libphone-ui_git.bb b/recipes/shr/libphone-ui_git.bb
new file mode 100644 (file)
index 0000000..84b04c5
--- /dev/null
@@ -0,0 +1,15 @@
+DESCRIPTION = "A generic framework for phone ui"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "libs"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+DEPENDS="glib-2.0 dbus-glib libframeworkd-glib libphone-utils alsa-lib"
+
+inherit pkgconfig autotools autotools_stage
+
+SRC_URI = "git://git.shr-project.org/repo/libphone-ui.git;protocol=http;branch=master"
+S="${WORKDIR}/git"
+
+CONFFILES_${PN} = "${sysconfdir}/libphoneui.conf"
diff --git a/recipes/shr/ologicd_git.bb b/recipes/shr/ologicd_git.bb
new file mode 100644 (file)
index 0000000..105199a
--- /dev/null
@@ -0,0 +1,9 @@
+DESCRIPTION = ""
+SECTION = "libs"
+PV = "0.0.1+gitr${SRCPV}"
+PR = "r0"
+
+inherit autotools
+
+SRC_URI = "git://shr.bearstech.com/repo/${PN}.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
diff --git a/recipes/shr/phonefsod_git.bb b/recipes/shr/phonefsod_git.bb
new file mode 100644 (file)
index 0000000..bc443a1
--- /dev/null
@@ -0,0 +1,31 @@
+DESCRIPTION = "SHR Phone FSO Daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib sqlite3 shr-specs"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "git://git.shr-project.org/repo/phonefsod.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "phonefsod"
+INITSCRIPT_PARAMS = "defaults 75"
+
+EXTRA_OECONF = "\
+       SPECS_PATH=${STAGING_DATADIR}/shr-specs \
+"
+
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/init.d/
+        install -d ${D}${sysconfdir}/dbus-1/system.d/
+       install -m 0755 ${S}/data/phonefsod.init ${D}${sysconfdir}/init.d/phonefsod
+        install -m 0644 ${S}/data/phonefsod.conf ${D}${sysconfdir}/dbus-1/system.d/
+       install -m 0644 ${S}/data/etc-phonefsod.conf ${D}${sysconfdir}/phonefsod.conf
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
diff --git a/recipes/shr/phoneui-apps_git.bb b/recipes/shr/phoneui-apps_git.bb
new file mode 100644 (file)
index 0000000..a1916df
--- /dev/null
@@ -0,0 +1,28 @@
+DESCRIPTION = "The PhoneUI app starters"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += "dbus-glib"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+inherit pkgconfig autotools
+
+SRC_URI = "git://git.shr-project.org/repo/phoneui-apps.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+PACKAGES = "${PN}-dialer ${PN}-messages ${PN}-contacts"
+
+FILES_${PN}-dialer = "\
+       /usr/bin/phoneui-dialer \
+       /usr/share/applications/phoneui-dialer.desktop \
+"
+FILES_${PN}-messages = "\
+       /usr/bin/phoneui-messages \
+       /usr/share/applications/phoneui-messages.desktop \
+"
+FILES_${PN}-contacts = "\
+       /usr/bin/phoneui-contacts \
+       /usr/share/applications/phoneui-contacts.desktop \
+"
+
diff --git a/recipes/shr/phoneuid_git.bb b/recipes/shr/phoneuid_git.bb
new file mode 100644 (file)
index 0000000..f866462
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "SHR Phone UI Daemon"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += " dbus-glib libframeworkd-glib libphone-ui sqlite3 shr-specs"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "git://git.shr-project.org/repo/phoneuid.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+       SPECS_PATH=${STAGING_DATADIR}/shr-specs \
+"
+
+
+do_install_append() {
+        install -d ${D}${sysconfdir}/dbus-1/system.d/
+       install -d ${D}${datadir}/dbus-1/system-services/
+       install -d ${D}${sysconfdir}/X11/Xsession.d/
+        install -m 0644 ${S}/data/phoneuid.conf ${D}${sysconfdir}/dbus-1/system.d/
+       install -m 0644 ${S}/data/phoneuid-*.service ${D}${datadir}/dbus-1/system-services/
+       install -m 0755 ${S}/data/80phoneuid ${D}${sysconfdir}/X11/Xsession.d/
+       install -m 0755 ${S}/data/phoneui-wrapper.sh ${D}${bindir}/phoneui-wrapper.sh
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"
+
diff --git a/recipes/shr/shr-config_git.bb b/recipes/shr/shr-config_git.bb
new file mode 100644 (file)
index 0000000..cc8d685
--- /dev/null
@@ -0,0 +1,14 @@
+DESCRIPTION = "Central settings app for FSO/SHR distros"
+HOMEPAGE = "http://git.freesmartphone.org"
+AUTHOR = "Sebastian Spaeth (see AUTHORS)"
+LICENSE  = "GPLv2"
+DEPENDS = "vala-native elementary libeflvala"
+SECTION = "x11/application"
+PV = "0.0.2+gitr${SRCPV}"
+PR = "r4"
+
+EXTRA_OECONF="--enable-vapidir=${STAGING_DATADIR}/vala/vapi"
+inherit autotools
+
+SRC_URI = "git://github.com/spaetz/shr-config.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
diff --git a/recipes/shr/shr-launcher_svn.bb b/recipes/shr/shr-launcher_svn.bb
new file mode 100644 (file)
index 0000000..ffd6161
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "shr-launcher is a home app/launcher for openmoko phones"
+HOMEPAGE = "http://code.google.com/p/shr-launcher/"
+AUTHOR = "cchandel"
+LICENSE = "GPLv2"
+SECTION = "e/apps"
+DEPENDS = "elementary eina edbus"
+
+PV = "0.0.1+svnr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "svn://shr-launcher.googlecode.com/svn/trunk;module=.;proto=http"
+
+do_configure_prepend() {
+  rm -f ${S}/config.log
+  rm -f ${S}/config.status
+}
+
+S = "${WORKDIR}"
+
+inherit autotools
+
diff --git a/recipes/shr/shr-settings_git.bb b/recipes/shr/shr-settings_git.bb
new file mode 100644 (file)
index 0000000..747f6d7
--- /dev/null
@@ -0,0 +1,32 @@
+DESCRIPTION = "Modular settings application for SHR based on python-elementary"
+HOMEPAGE = "http://shr-project.org"
+SHR_RELEASE ?= "shr"
+LICENSE ?= "GPL"
+RDEPENDS = "python-elementary python-dbus python-codecs python-shell python-pyrtc python python-core python-edbus dbus-x11 frameworkd python-phoneutils"
+SECTION = "x11/application"
+PE = "1"
+PV = "0.1.1+gitr${SRCPV}"
+PR = "r7"
+
+inherit setuptools
+
+PACKAGES =+ "\
+  ${PN}-addons-illume \
+  ${PN}-backup-configuration \
+"
+
+RRECOMMENDS_${PN} = "\
+  ${PN}-addons-illume \
+  ${PN}-backup-configuration \
+"
+
+PACKAGE_ARCH_${PN}-addons-illume = "all"
+PACKAGE_ARCH_${PN}-backup-configuration = "all"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-settings.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+FILES_${PN} += "${prefix}/share/pixmaps"
+FILES_${PN} += "${prefix}/share/applications"
+FILES_${PN}-addons-illume = "${prefix}/share/applications/shr-settings-addons-illume"
+FILES_${PN}-backup-configuration = "${sysconfdir}/shr-settings/"
+CONFFILES_${PN}-backup-configuration = "${sysconfdir}/shr-settings/*"
diff --git a/recipes/shr/shr-specs_git.bb b/recipes/shr/shr-specs_git.bb
new file mode 100644 (file)
index 0000000..bc29ee5
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "The SHR DBus API Specification"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "BSD"
+SECTION = "devel/specifications"
+PV = "0.0.0+gitr${SRCPV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-specs.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+do_compile() {
+       make xml
+}
+
+do_stage() {
+       install -d "${STAGING_DATADIR}/shr-specs"
+       install -m 0644 xml/* "${STAGING_DATADIR}/shr-specs"
+}
+
+FILE_${PN}-dev += "${datadir}/shr-specs"
+
+