libpcap: add patch to use LDFLAGS (fixes QA error)
authorJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 13:56:49 +0000 (13:56 +0000)
committerJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 13:56:49 +0000 (13:56 +0000)
recipes/libpcap/libpcap-1.0.0/ldflags.patch [new file with mode: 0644]
recipes/libpcap/libpcap_1.0.0.bb

diff --git a/recipes/libpcap/libpcap-1.0.0/ldflags.patch b/recipes/libpcap/libpcap-1.0.0/ldflags.patch
new file mode 100644 (file)
index 0000000..66ab5f7
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN libpcap-1.0.0.orig/Makefile.in libpcap-1.0.0/Makefile.in
+--- libpcap-1.0.0.orig/Makefile.in     2008-10-28 01:26:13.000000000 +0000
++++ libpcap-1.0.0/Makefile.in  2009-04-02 13:54:20.000000000 +0000
+@@ -326,7 +326,7 @@
+ #
+ libpcap.so: $(OBJ)
+       @rm -f $@
+-      $(CC) -shared -Wl,-soname,$@.1 -o $@.`cat $(srcdir)/VERSION` $(OBJ) $(DAGLIBS)
++      $(CC) $(LDFLAGS) -shared -Wl,-soname,$@.1 -o $@.`cat $(srcdir)/VERSION` $(OBJ) $(DAGLIBS)
+ #
+ # The following rule succeeds, but the result is untested.
index b85bf4c..6dfc056 100644 (file)
@@ -1,9 +1,10 @@
 require libpcap.inc
 
-PR = "r5"
+PR = "r6"
 SRC_URI = "http://www.tcpdump.org/release/libpcap-${PV}.tar.gz"
 SRC_URI += "file://aclocal.patch;patch=1"
 SRC_URI += "file://ieee80215-arphrd.patch;patch=1"
+SRC_URI += "file://ldflags.patch;patch=1"
 
 do_compile () {
     oe_runmake