libsdl-mixer: fix it the same way as the libsdl recipe and bump PR
authorHenning Heinold <heinold@inf.fu-berlin.de>
Fri, 11 Feb 2011 08:38:06 +0000 (09:38 +0100)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Fri, 11 Feb 2011 09:02:00 +0000 (10:02 +0100)
recipes/libsdl/libsdl-mixer_1.2.11.bb

index 498f359..d495503 100644 (file)
@@ -4,15 +4,13 @@ PRIORITY = "optional"
 DEPENDS = "virtual/libsdl flac libmikmod libvorbis  ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
 LICENSE = "LGPL"
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
            file://fix-flac-madness.diff"
 
 S = "${WORKDIR}/SDL_mixer-${PV}"
 
-export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
-
 inherit autotools
 
 # Although we build SMPEG lets not use it as it is pointless in the embedded space.
@@ -20,14 +18,18 @@ inherit autotools
 # Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
 # Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
 
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
+EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
 
-do_compile() {
-       # Override SDL_LIBS to include a linker rpath so the linker
-       # can find the correct libdl.so when it links playwave to
-       # libSDL_mixer.so.
-       oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+do_configure_prepend () {
+        # Remove old libtool macros.
+        MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+        for i in ${MACROS}; do
+               rm -f acinclude/$i
+        done
+        export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
 }
 
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
+
 SRC_URI[md5sum] = "65ada3d997fe85109191a5fb083f248c"
 SRC_URI[sha256sum] = "86145ac39cac6d2c6169c226f937648dca5e89dcd828751763dd174fa9af9cf9"