connman: fix initscript and start earlier (but after dbus) (from poky)
authorKoen Kooi <koen@openembedded.org>
Mon, 1 Jun 2009 13:53:10 +0000 (15:53 +0200)
committerKoen Kooi <koen@openembedded.org>
Mon, 1 Jun 2009 13:53:10 +0000 (15:53 +0200)
recipes/connman/connman.inc
recipes/connman/connman_0.19.bb
recipes/connman/files/connman

index c79c22c..516684d 100644 (file)
@@ -14,7 +14,7 @@ EXTRA_OECONF += "\
 "
 
 INITSCRIPT_NAME = "connman"
-INITSCRIPT_PARAMS = "defaults 22"
+INITSCRIPT_PARAMS = "start 05 5 2 . stop 22 0 1 6 ."
 
 PARALLEL_MAKE = ""
 
index b8d8661..26b7b82 100644 (file)
@@ -1,5 +1,7 @@
 require connman.inc
 
+PR = "r1"
+
 EXTRA_OECONF += "\
   --disable-gtk-doc \
   --enable-debug \
index 5e0f90e..f8154f6 100755 (executable)
@@ -11,7 +11,7 @@ fi
 set -e
 
 do_start() {
-       connmand 
+       $DAEMON
 }
 
 do_stop() {