linux-firmware: update to current git and split out the wl12xx stuff that was added...
authorKoen Kooi <koen@openembedded.org>
Wed, 23 Feb 2011 14:23:37 +0000 (15:23 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 23 Feb 2011 14:23:37 +0000 (15:23 +0100)
Signed-off-by: Koen Kooi <koen@openembedded.org>
recipes/linux-firmware/linux-firmware_git.bb

index 7bff379..d4a0611 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Firmware files for use with Linux kernel"
 
 PR_append = "+gitr${SRCREV}"
-SRCREV = "80a203275fc368db0a5f166c42dd35a4a22f2453"
+SRCREV = "1fbf358d5d039eab184963a9999e19aa5188cf60"
 
 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/dwmw2/linux-firmware.git;protocol=git"
 
@@ -14,8 +14,14 @@ do_compile() {
 do_install() {
        install -d  ${D}/lib/firmware/
        cp -RpP * ${D}/lib/firmware/
+
+       # fixup wl12xx location
+       mv ${D}/lib/firmware/ti-connectivity/* ${D}/lib/firmware 
 }
 
+PACKAGES =+ "${PN}-wl12xx"
+FILES_${PN}-wl12xx = "/lib/firmware/wl12*"
+
 FILES_${PN} += "/lib/firmware/*"
 PACKAGE_ARCH = "all"