glib-2.0_2.22.4.bb : fix native build issues
authorGraeme Gregory <dp@xora.org.uk>
Sun, 7 Feb 2010 16:02:08 +0000 (16:02 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Sun, 7 Feb 2010 16:02:08 +0000 (16:02 +0000)
because we override the DEPENDS variable need to make sure that pkgconfig-native
is built otherwise configure script is incorrect.

recipes/glib-2.0/glib-2.0_2.22.4.bb

index eff5fbd..1d10c41 100644 (file)
@@ -22,7 +22,7 @@ SRC_URI_append_arm = " file://atomic-thumb.patch;patch=1"
 SRC_URI_append_armv6 = " file://gatomic_armv6.patch;patch=1"
 SRC_URI_append_armv7a = " file://gatomic_armv6.patch;patch=1" 
 
-PR = "r0"
+PR = "r1"
 
 inherit autotools gettext
 
@@ -41,7 +41,8 @@ do_install_append() {
        sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g ${D}${bindir}/glib-mkenums || true
 }
 
-DEPENDS_virtclass-native = "gettext-native gtk-doc-native"
+DEPENDS_virtclass-native = "gettext-native gtk-doc-native libpcre-native \
+                            pkgconfig-native"
 EXTRA_OECONF_virtclass-native = ""
 
 do_configure_prepend_virtclass-native() {