gthumb_2.10.11.bb : add a hack to make it look at sysroot not /
authorGraeme Gregory <dp@xora.org.uk>
Thu, 28 Jan 2010 14:20:07 +0000 (14:20 +0000)
committerGraeme Gregory <dp@xora.org.uk>
Thu, 28 Jan 2010 14:22:07 +0000 (14:22 +0000)
I found that the pkg-config sysroot support doesnt extend to variables
so some extra munging was needed to point this at the correct IDL files.

recipes/gthumb/gthumb/pkg-config-hack.patch [new file with mode: 0644]
recipes/gthumb/gthumb_2.10.11.bb

diff --git a/recipes/gthumb/gthumb/pkg-config-hack.patch b/recipes/gthumb/gthumb/pkg-config-hack.patch
new file mode 100644 (file)
index 0000000..e9981d1
--- /dev/null
@@ -0,0 +1,7 @@
+Index: gthumb-2.10.11/add-include-prefix
+===================================================================
+--- gthumb-2.10.11.orig/add-include-prefix
++++ gthumb-2.10.11/add-include-prefix
+@@ -1 +1 @@
+-sed -e 's/^/ /' -e 's/ \+$//' -e 's/ / -I /g' -e 's/^ \+//'
++sed -e 's|^| |' -e 's| \+$||' -e 's| | -I HACK_STAGING_DIR_HOST|g' -e 's|^ \+||'
index 94f37a0..436d506 100644 (file)
@@ -5,10 +5,13 @@ DEPENDS = "gtk+ libexif libgnome libgnomeui libgnomeprintui"
 
 inherit gnome
 
-PR = "r1"
+SRC_URI += "file://pkg-config-hack.patch;patch=1"
+
+PR = "r2"
 
 FILES_${PN} += "${libdir}/*.so ${datadir}/gnome* ${datadir}/application-registry/*"
 FILES_${PN}-dbg += "${libdir}/gthumb/modules/.debug"
 
-
-
+do_configure_prepend() {
+       sed -i "s|HACK_STAGING_DIR_HOST|${STAGING_DIR_HOST}|" ${S}/add-include-prefix
+}