squashfs-tools-4.0: Use LDFLAGS in Makefile.
authorLeon Woestenberg <leon@sidebranch.com>
Mon, 8 Mar 2010 10:50:18 +0000 (11:50 +0100)
committerLeon Woestenberg <leon@sidebranch.com>
Mon, 8 Mar 2010 10:54:46 +0000 (11:54 +0100)
LDFLAGS was not used. Fixed that.

The staged zlib was not picked up on a system that hadn't zlib-dev
installed natively.

Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
recipes/squashfs-tools/squashfs-tools-4.0/Makefile.patch
recipes/squashfs-tools/squashfs-tools_4.0.bb

index 2c88aba..546847e 100644 (file)
@@ -1,60 +1,22 @@
 Index: squashfs-tools/Makefile
 ===================================================================
---- squashfs-tools.orig/Makefile       2009-04-19 01:47:43.000000000 +0200
-+++ squashfs-tools/Makefile    2009-04-19 01:52:36.000000000 +0200
-@@ -1,36 +1,48 @@
- INSTALL_DIR = /usr/local/bin
- INCLUDEDIR = .
-+CFLAGS_R = -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
-+LIBS = -lz -lpthread
- CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
+--- squashfs-tools.orig/Makefile       2010-03-08 11:17:18.009403053 +0100
++++ squashfs-tools/Makefile    2010-03-08 11:18:04.240910008 +0100
+@@ -51,7 +51,7 @@
  all: mksquashfs unsquashfs
  
- mksquashfs: mksquashfs.o read_fs.o sort.o swap.o pseudo.o
--      $(CC) mksquashfs.o read_fs.o sort.o swap.o pseudo.o -lz -lpthread -lm -o $@
-+      $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o swap.o pseudo.o -lz -lpthread -lm -o $@
- mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h squashfs_swap.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
- read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h squashfs_swap.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
- sort.o: sort.c squashfs_fs.h global.h sort.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
- swap.o: swap.c Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
- pseudo.o: pseudo.c pseudo.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
- unsquashfs: unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o
--      $(CC) unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o -lz -lpthread -lm -o $@
-+      $(CC) $(LDFLAGS) unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o -lz -lpthread -lm -o $@
--unsquashfs.o: unsquashfs.h unsquashfs.c squashfs_fs.h squashfs_swap.h squashfs_compat.h global.h Makefile
-+unsquashfs.o: unsquashfs.c unsquashfs.h squashfs_fs.h squashfs_swap.h squashfs_compat.h global.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
--unsquash-1.o: unsquashfs.h unsquash-1.c squashfs_fs.h squashfs_compat.h global.h Makefile
-+unsquash-1.o: unsquash-1.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
--unsquash-2.o: unsquashfs.h unsquash-2.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
-+unsquash-2.o: unsquash-2.c unsquashfs.h unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ mksquashfs: $(MKSQUASHFS_OBJS)
+-      $(CC) $(MKSQUASHFS_OBJS) -lz -lpthread -lm $(LIBS) -o $@
++      $(CC) $(LDFLAGS) $(MKSQUASHFS_OBJS) -lz -lpthread -lm $(LIBS) -o $@
  
--unsquash-3.o: unsquashfs.h unsquash-3.c squashfs_fs.h squashfs_compat.h global.h Makefile
-+unsquash-3.o: unsquash-3.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h \
+       squashfs_swap.h
+@@ -67,7 +67,7 @@
+ compressor.o: compressor.c compressor.h
  
--unsquash-4.o: unsquashfs.h unsquash-4.c squashfs_fs.h squashfs_swap.h global.h Makefile
-+unsquash-4.o: unsquash-4.c unsquashfs.h squashfs_fs.h squashfs_swap.h global.h Makefile
-+      $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
+ unsquashfs: $(UNSQUASHFS_OBJS)
+-      $(CC) $(UNSQUASHFS_OBJS) -lz -lpthread -lm $(LIBS) -o $@
++      $(CC) $(LDFLAGS) $(UNSQUASHFS_OBJS) -lz -lpthread -lm $(LIBS) -o $@
  
- clean:
-       -rm -f *.o mksquashfs unsquashfs
+ unsquashfs.o: unsquashfs.h unsquashfs.c squashfs_fs.h squashfs_swap.h \
+       squashfs_compat.h global.h
index 886c095..1f58f13 100644 (file)
@@ -1,9 +1,10 @@
 # This override is required since this has not yet been released
 SRC_URI  = "cvs://anonymous@squashfs.cvs.sourceforge.net/cvsroot/squashfs;module=squashfs;date=${SRCDATE} \
             http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2"
+SRC_URI += " file://Makefile.patch;patch=1"
 
 require squashfs-tools.inc
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
 
 S = "${WORKDIR}/squashfs/squashfs-tools"