fsodatad: add a config file
authorKlaus Kurzmann <mok@fluxnetz.de>
Sat, 9 Jan 2010 20:53:57 +0000 (21:53 +0100)
committerKlaus Kurzmann <mok@fluxnetz.de>
Sat, 9 Jan 2010 20:53:57 +0000 (21:53 +0100)
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
recipes/freesmartphone/fsodatad/fsodatad.conf [new file with mode: 0644]
recipes/freesmartphone/fsodatad_git.bb

diff --git a/recipes/freesmartphone/fsodatad/fsodatad.conf b/recipes/freesmartphone/fsodatad/fsodatad.conf
new file mode 100644 (file)
index 0000000..85919cf
--- /dev/null
@@ -0,0 +1,19 @@
+#######################################################################################
+# FSO Data Daemon Configuration File -- for SYSTEM INTEGRATORS only
+########################################################################################
+[logging]
+# Log level: DEBUG, INFO (default), WARNING, ERROR
+# Override via environment as FSO_LOG_LEVEL
+log_level = INFO
+# Where to log to: none (default), stderr, stderr:colors, file, syslog
+# Override via environment as FSO_LOG_TO
+log_to = file
+# Log Destination (valid only for log_to = file)
+# Override via environment as FSO_LOG_DESTINATION
+log_destination = /var/log/fsodatad.log
+
+[fsodata]
+# No settings yet
+
+[fsodata.world]
+# No settings yet
index de13bed..c2933ed 100644 (file)
@@ -1,6 +1,15 @@
 require cornucopia.inc
 inherit fso-plugin
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 PV = "0.0.0+gitr${SRCREV}"
 
 DEPENDS += "libxml2 mobile-broadband-provider-info"
+
+SRC_URI += "file://fsodatad.conf"
+
+do_install_append() {
+       install -d ${D}${sysconfdir}/freesmartphone/
+       install -m 0644 ${WORKDIR}/fsodatad.conf ${D}${sysconfdir}/freesmartphone/
+}
+
+FILES_${PN} += "${sysconfdir}/freesmartphone/fsodatad.conf"