gpsd: add 2.95 version which fixes python binding issues
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>
Fri, 27 Aug 2010 15:52:30 +0000 (17:52 +0200)
committerGrazvydas Ignotas <notasas@gmail.com>
Wed, 23 Jul 2014 22:05:53 +0000 (01:05 +0300)
gpsd 2.94 is known to have python binding issues:
*From #gpsd in Freenode:
  Aug 26 14:48:15 <lindi-> GNUtoo|laptop: hmm, 2.94 sounds suspicious, i think the python bindings were bit buggy at that time
*And I tried a python test program available here:
    http://lindi.iki.fi/lindi/gpsd/gpsd-get-position3
  It failed to print something when a fix was there
    with 2.94 and succeded with  2.95

libtool.patch was rebased
configure-libusb.patch didn't need to be rebased as it landed upstream

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
recipes/gpsd/gpsd-2.95/libtool.patch [new file with mode: 0644]
recipes/gpsd/gpsd_2.95.bb [new file with mode: 0644]

diff --git a/recipes/gpsd/gpsd-2.95/libtool.patch b/recipes/gpsd/gpsd-2.95/libtool.patch
new file mode 100644 (file)
index 0000000..7b78a72
--- /dev/null
@@ -0,0 +1,16 @@
+Index: gpsd-2.95/Makefile.am
+===================================================================
+--- gpsd-2.95.orig/Makefile.am 2010-08-26 15:31:38.804330723 +0200
++++ gpsd-2.95/Makefile.am      2010-08-26 15:31:57.170020341 +0200
+@@ -253,9 +253,9 @@
+ # Warning: This overrides autoconf's normal link-line generation process
+ if LIBGPSMM_ENABLE
+ libgps_la_SOURCES += libgpsmm.cpp
+-libgps_la_LINK = /bin/sh ./libtool --tag=CXX --mode=link g++ $(libgps_la_LDFLAGS) -o $@
++libgps_la_LINK = $(LIBTOOL) --tag=CXX --mode=link g++ $(libgps_la_LDFLAGS) -o $@
+ else
+-libgps_la_LINK = /bin/sh ./libtool --tag=CC --mode=link gcc $(libgps_la_LDFLAGS) -o $@
++libgps_la_LINK = $(LIBTOOL) --tag=CC --mode=link gcc $(libgps_la_LDFLAGS) -o $@
+ endif
+ nodist_libgpsd_la_SOURCES = packet_names.h ais_json.i
diff --git a/recipes/gpsd/gpsd_2.95.bb b/recipes/gpsd/gpsd_2.95.bb
new file mode 100644 (file)
index 0000000..27aa851
--- /dev/null
@@ -0,0 +1,14 @@
+require gpsd.inc
+
+DEPENDS += "libusb1"
+
+SRC_URI += "file://libtool.patch \
+          "
+EXTRA_OECONF += "--disable-libQgpsmm"
+
+SRC_URI[gpsd.md5sum] = "12535a9ed9fecf9ea2c5bdc9840da5ae"
+SRC_URI[gpsd.sha256sum] = "832343a53921a8371efa540ba57c91dadedda445e571c1beb97c06539ef450ae"
+
+PR = "${INC_PR}.0"
+
+PARALLEL_MAKE = ""