swig : Fix recipe so it works on target, convert to BBCLASSEXTEND and .inc file.
authorPhilip Balister <philip@balister.org>
Wed, 27 Jan 2010 22:55:42 +0000 (17:55 -0500)
committerPhilip Balister <philip@balister.org>
Wed, 27 Jan 2010 22:58:15 +0000 (17:58 -0500)
       * native packages now use BBCLASSEXTEND method.
       * Now installs need files into target.
       * include file to eliminate duplicate portions of the recipe.

recipes/swig/swig-native_1.3.31.bb [deleted file]
recipes/swig/swig-native_1.3.38.bb [deleted file]
recipes/swig/swig-native_1.3.39.bb [deleted file]
recipes/swig/swig.inc [new file with mode: 0644]
recipes/swig/swig_1.3.31.bb
recipes/swig/swig_1.3.38.bb
recipes/swig/swig_1.3.39.bb

diff --git a/recipes/swig/swig-native_1.3.31.bb b/recipes/swig/swig-native_1.3.31.bb
deleted file mode 100644 (file)
index 8210bb9..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-require swig_${PV}.bb
-inherit native
-
-do_stage() {
-       oe_runmake install PREFIX=${STAGING_BINDIR}/..
-}
-
diff --git a/recipes/swig/swig-native_1.3.38.bb b/recipes/swig/swig-native_1.3.38.bb
deleted file mode 100644 (file)
index 8210bb9..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-require swig_${PV}.bb
-inherit native
-
-do_stage() {
-       oe_runmake install PREFIX=${STAGING_BINDIR}/..
-}
-
diff --git a/recipes/swig/swig-native_1.3.39.bb b/recipes/swig/swig-native_1.3.39.bb
deleted file mode 100644 (file)
index 8210bb9..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-require swig_${PV}.bb
-inherit native
-
-do_stage() {
-       oe_runmake install PREFIX=${STAGING_BINDIR}/..
-}
-
diff --git a/recipes/swig/swig.inc b/recipes/swig/swig.inc
new file mode 100644 (file)
index 0000000..30d556c
--- /dev/null
@@ -0,0 +1,16 @@
+DESCRIPTION = "SWIG - Simplified Wrapper and Interface Generator"
+HOMEPAGE = "http://swig.sourceforge.net/"
+LICENSE = "BSD"
+SECTION = "devel"
+INC_PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
+
+inherit autotools
+
+BBCLASSEXTEND = "native"
+
+do_configure() {
+       oe_runconf
+}
+
index 8a8138c..b245ded 100644 (file)
@@ -1,16 +1,4 @@
-DESCRIPTION = "SWIG - Simplified Wrapper and Interface Generator"
-HOMEPAGE = "http://swig.sourceforge.net/"
-LICENSE = "BSD"
-SECTION = "devel"
+require swig.inc
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/swig/swig-${PV}.tar.gz"
-S = "${WORKDIR}/swig-${PV}"
-
-inherit autotools
-
-EXTRA_OECONF = "--with-python=${STAGING_BINDIR_NATIVE} --with-swiglibdir=${STAGING_DIR_NATIVE}/swig"
-
-do_configure() {
-       oe_runconf
-}
+PR = "${INC_PR}.0"
 
index 8a8138c..b245ded 100644 (file)
@@ -1,16 +1,4 @@
-DESCRIPTION = "SWIG - Simplified Wrapper and Interface Generator"
-HOMEPAGE = "http://swig.sourceforge.net/"
-LICENSE = "BSD"
-SECTION = "devel"
+require swig.inc
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/swig/swig-${PV}.tar.gz"
-S = "${WORKDIR}/swig-${PV}"
-
-inherit autotools
-
-EXTRA_OECONF = "--with-python=${STAGING_BINDIR_NATIVE} --with-swiglibdir=${STAGING_DIR_NATIVE}/swig"
-
-do_configure() {
-       oe_runconf
-}
+PR = "${INC_PR}.0"
 
index 8a8138c..02364ce 100644 (file)
@@ -1,16 +1,5 @@
-DESCRIPTION = "SWIG - Simplified Wrapper and Interface Generator"
-HOMEPAGE = "http://swig.sourceforge.net/"
-LICENSE = "BSD"
-SECTION = "devel"
+require swig.inc
 
-SRC_URI = "${SOURCEFORGE_MIRROR}/swig/swig-${PV}.tar.gz"
-S = "${WORKDIR}/swig-${PV}"
-
-inherit autotools
-
-EXTRA_OECONF = "--with-python=${STAGING_BINDIR_NATIVE} --with-swiglibdir=${STAGING_DIR_NATIVE}/swig"
-
-do_configure() {
-       oe_runconf
-}
+PR = "${INC_PR}.0"
 
+DEFAULT_PREFERENCE = "-1"