udev 151: create modules.dep if it doesn't exist, fixes scary warnings at first boot
authorKoen Kooi <koen@openembedded.org>
Thu, 11 Mar 2010 11:01:36 +0000 (12:01 +0100)
committerKoen Kooi <koen@openembedded.org>
Thu, 11 Mar 2010 11:12:53 +0000 (12:12 +0100)
recipes/udev/udev-151/init
recipes/udev/udev_151.bb

index 66705e6..f4dc5de 100644 (file)
@@ -49,6 +49,11 @@ if [ "$DEVCACHE" != "" ]; then
        fi
 fi
 
+if [ ! -e "/lib/modules/$(uname -r)"/modules.dep ] ; then
+       mkdir -p /lib/modules/$(uname -r)
+       depmod -ae
+fi
+
 # make_extra_nodes
 kill_udevd > "/dev/null" 2>&1
 
index ee31b27..1aca146 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
 the hotplug package and requires a kernel not older than 2.6.12."
 LICENSE = "GPL"
 
-PR = "r3"
+PR = "r4"
 
 # Untested
 DEFAULT_PREFERENCE = "-1"