pulseaudio: add git version
authorKoen Kooi <koen@openembedded.org>
Tue, 1 Mar 2011 13:14:53 +0000 (14:14 +0100)
committerKoen Kooi <koen@openembedded.org>
Tue, 1 Mar 2011 13:16:23 +0000 (14:16 +0100)
armv4t/armv4t patches were not forward ported, so don't use this on those archs

Signed-off-by: Koen Kooi <koen@openembedded.org>
recipes/pulseaudio/pulseaudio_git.bb [new file with mode: 0644]

diff --git a/recipes/pulseaudio/pulseaudio_git.bb b/recipes/pulseaudio/pulseaudio_git.bb
new file mode 100644 (file)
index 0000000..28c5814
--- /dev/null
@@ -0,0 +1,36 @@
+require pulseaudio.inc
+
+SRCREV = "f834150aceccd753e3ac5bab9f7d64bed9993624"
+PV = "0.9.22+git"
+PR = "${INC_PR}.0-r${SRCPV}"
+
+DEPENDS += "orc gdbm speex"
+
+DEFAULT_PREFERENCE = "-1"
+
+FILESPATHPKG =. "pulseaudio-0.9.21:"
+
+inherit gettext
+
+SRC_URI = "git://git.0pointer.de/pulseaudio.git;protocol=git \
+           file://gcc4-compile-fix.patch \
+           file://volatiles.04_pulse \
+           file://autoconf_version.patch \
+           file://tls_m4.patch \
+"
+
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+       touch config.rpath
+}
+
+# orc.m4 calls pkg-config ----variable=orcc orc-0.4 to get the path to orcc,
+# resulting in /usr/bin/orcc. Force it to use the staged orcc.
+do_configure_append() {
+    for i in $(find ${S} -name "Makefile") ; do
+        sed -i -e s:${bindir}/orcc:${STAGING_BINDIR_NATIVE}/orcc:g $i
+    done
+}
+
+