dropbear: Enable allow empty password patch.
authorKhem Raj <raj.khem@gmail.com>
Fri, 4 Sep 2009 04:19:42 +0000 (21:19 -0700)
committerKhem Raj <raj.khem@gmail.com>
Fri, 4 Sep 2009 04:23:21 +0000 (21:23 -0700)
* Switch to using INC_PR
* Enable allow-empty_passed.patch without this
its not possible to login unless root password
is changed to be non empty

Signed-off-by: Khem Raj <raj.khem@gmail.com>
recipes/dropbear/dropbear-early_1.0.bb
recipes/dropbear/dropbear.inc
recipes/dropbear/dropbear_0.49.bb
recipes/dropbear/dropbear_0.51.bb
recipes/dropbear/dropbear_0.52.bb

index c947cf0..3500670 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Allow to start dropbear soon after boot, depending on kernel command line option."
 SECTION = "devel"
 RDEPENDS = "dropbear"
-PR = "r3"
+PR = "${INC_PR}.0"
 
 SRC_URI = "file://dropbear-early"
 
index 364799f..2e3b7dd 100644 (file)
@@ -6,12 +6,14 @@ DEPENDS = "zlib"
 PROVIDES = "ssh sshd"
 RPROVIDES = "ssh sshd"
 
+INC_PR = "r3"
+
 SRC_URI = "\
   http://matt.ucc.asn.au/dropbear/dropbear-${PV}.tar.bz2 \
   file://urandom-xauth-changes-to-options.h.patch;patch=1 \
   file://configure.patch;patch=1 \
   file://fix-2kb-keys.patch;patch=1 \
-  file://allow-nopw.patch \
+  file://allow-nopw.patch;patch=1 \
   file://init \
 "
 SRC_URI_append_openmoko = "\
index bf2f2ad..9d45ea0 100644 (file)
@@ -1,5 +1,5 @@
 require dropbear.inc
 
-PR = "r2"
+PR = "${INC_PR}.0"
 
 SRC_URI += "file://scp-argument-fix.patch;patch=1"
index 2566fbb..cdd312c 100644 (file)
@@ -1,4 +1,3 @@
 require dropbear.inc
-PR = "r1.01"
-
+PR = "${INC_PR}.0"
 SRC_URI += "file://no-host-lookup.patch;patch=1"
index 6b2517b..6130e50 100644 (file)
@@ -1,6 +1,5 @@
 require dropbear.inc
-PR = "r0"
-
+PR = "${INC_PR}.0"
 SRC_URI += "file://no-host-lookup.patch;patch=1"
 
 DEFAULT_PREFERENCE = "-1"