parted: add 1.8.7
authorKoen Kooi <koen@openembedded.org>
Thu, 14 Jun 2007 08:30:35 +0000 (08:30 +0000)
committerKoen Kooi <koen@openembedded.org>
Thu, 14 Jun 2007 08:30:35 +0000 (08:30 +0000)
packages/parted/parted_1.8.7.bb [new file with mode: 0644]

diff --git a/packages/parted/parted_1.8.7.bb b/packages/parted/parted_1.8.7.bb
new file mode 100644 (file)
index 0000000..f29771d
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "parted, the GNU partition resizing program"
+HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
+LICENSE = "GPLv2"
+SECTION = "console/tools"
+DEPENDS = "readline e2fsprogs-libs"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz"
+           
+EXTRA_OECONF = "--disable-Werror"
+
+inherit autotools pkgconfig
+
+do_configure() {
+        libtoolize --force
+        gnu-configize
+        oe_runconf
+}
+
+do_stage() {
+       autotools_stage_all
+}