hal: update to 0.5.13
authorKoen Kooi <koen@openembedded.org>
Tue, 21 Jul 2009 10:30:22 +0000 (12:30 +0200)
committerKoen Kooi <koen@openembedded.org>
Tue, 21 Jul 2009 10:30:22 +0000 (12:30 +0200)
conf/checksums.ini
recipes/hal/hal_0.5.13.bb [new file with mode: 0644]

index d801da7..686a1bb 100644 (file)
@@ -10418,6 +10418,10 @@ sha256=730a9f2340f789677eb0c3b0984bbaca3ede6c12d1e4b16bc7ea91f51d10ba90
 md5=bb7c36e142437f7363f9a80ae8391926
 sha256=c444e0485e4361eec0e6f06580c45b9fcf6f20a119634a5f0a5c13218cfdfd02
 
+[http://hal.freedesktop.org/releases/hal-0.5.13.tar.gz]
+md5=46ecc5d2e5bd964fb78099688f01bb6a
+sha256=ebcf22a373761530920643add1a791af40954dc7349f027d1c35b0e0f7f9c8af
+
 [http://freedesktop.org/~david/dist/hal-0.5.2.tar.gz]
 md5=3b351822ba359669646026013a3d5a03
 sha256=46d0a75f90058909269da4cc42986cd51d5163a6af669e9d7fb4a7d170217d17
diff --git a/recipes/hal/hal_0.5.13.bb b/recipes/hal/hal_0.5.13.bb
new file mode 100644 (file)
index 0000000..c5d9f65
--- /dev/null
@@ -0,0 +1,12 @@
+require hal.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+# The following code finds the right linux/input.h,
+# which also works with external-toolchain/SDK
+do_configure() {
+       sed -i -e s:1.43:1.41:g ${S}/configure.in
+       linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
+               grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
+       autotools_do_configure --with-linux-input-header=${linux_input_h}
+}