ti-codec: add missing.inc
authorKoen Kooi <koen@openembedded.org>
Wed, 26 Aug 2009 14:10:27 +0000 (16:10 +0200)
committerKoen Kooi <koen@openembedded.org>
Wed, 26 Aug 2009 14:10:27 +0000 (16:10 +0200)
bitblit: add svn recipe

recipes/ti/bitblit/recent-linux.diff [new file with mode: 0644]
recipes/ti/bitblit_svn.bb [new file with mode: 0644]
recipes/ti/ti-codec.inc [new file with mode: 0644]

diff --git a/recipes/ti/bitblit/recent-linux.diff b/recipes/ti/bitblit/recent-linux.diff
new file mode 100644 (file)
index 0000000..753438a
--- /dev/null
@@ -0,0 +1,41 @@
+Index: trunk/bitblit/packages/ti/sdo/apps/bitblit_test/linux/framebuffer.c
+===================================================================
+--- trunk/bitblit/packages/ti/sdo/apps/bitblit_test/linux/framebuffer.c        (revision 2)
++++ trunk/bitblit/packages/ti/sdo/apps/bitblit_test/linux/framebuffer.c        (working copy)
+@@ -53,9 +53,7 @@
+ #include <linux/fb.h>
+ /* Davinci/OMAP specific kernel headers */
+-#ifdef _omap3530
+-#include <video/omapfbdev.h>
+-#else
++#ifndef _omap3530
+ #include <video/davincifb_ioctl.h>
+ #endif
+@@ -248,9 +246,11 @@
+     if (waitForVsync) {
+         /* Wait for vertical sync */
+         /* Assumption is that rgb and alpha flip together - only wait on rgb */
++#if defined (FBIO_WAITFORVSYNC)
+         if (ioctl(hDisplay->fd, FBIO_WAITFORVSYNC, &dummy) == -1) {
+-            printf("Failed FBIO_WAITFORVSYNC (%s)\n", strerror(errno));
++           printf("Failed FBIO_WAITFORVSYNC (%s)\n", strerror(errno));
+         }
++#endif
+     }
+ #endif  /* #ifdef _DMAI */
+@@ -276,10 +276,12 @@
+     
+     /* Wait for vertical sync */
+     /* Assumption is that rgb and alpha flip together - only wait on rgb */
++#if defined (FBIO_WAITFORVSYNC)
+     if (ioctl(hDisplay->fd, FBIO_WAITFORVSYNC, &dummy) == -1) {
+         printf("Failed FBIO_WAITFORVSYNC (%s)\n", strerror(errno));
+     }
+ #endif
++#endif
+ }
diff --git a/recipes/ti/bitblit_svn.bb b/recipes/ti/bitblit_svn.bb
new file mode 100644 (file)
index 0000000..9a0a241
--- /dev/null
@@ -0,0 +1,48 @@
+DESCRIPTION = "Low level 2D blitting/blending graphics acceleration services support on DM6446, OMAP3530 and OMAP-L137."
+
+require ti-paths.inc
+
+inherit autotools
+
+DEPENDS = "ti-codec-engine ti-dmai"
+
+# Fetch source from svn repo
+SRCREV = "2"
+SRC_URI = "svn://gforge.ti.com/svn/${PN};module=trunk;proto=https;user=anonymous;pswd='' \
+           file://recent-linux.diff;patch=1 \
+"
+
+# Again, no '.' in PWD allowed :(
+PV = "0+svnr${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/trunk/bitblit"
+
+XDC_TARGET                             = gnu.targets.arm.GCArmv5T
+XDC_PLATFORM_dm355-evm                 = ti.platforms.evmDM355
+XDC_PLATFORM_dm6446-evm        = ti.platforms.evmDM6446
+XDC_PLATFORM_da830-omapl137-evm        = ti.platforms.omapl137
+PLATFORM_XDC                           = ${XDC_PLATFORM}
+
+export XDC_TARGET
+export XDC_PLATFORM
+export PLATFORM_XDC 
+
+PLATFORM_dm355-evm                     = "dm355"
+PLATFORM_dm6446-evm            = "dm6446"
+PLATFORM_da830-omapl137-evm = "ol137"
+
+export LINUXLIBS_INSTALL_DIR="${STAGING_DIR_HOST}/usr"
+export EXEC_DIR = "${D}${datadir}/ti/bitblit/"
+
+CPPFLAGS_append                        = " -DPlatform_${PLATFORM}"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_compile() {
+       oe_runmake -e all
+}
+
+do_install() {
+       oe_runmake -e install
+}
diff --git a/recipes/ti/ti-codec.inc b/recipes/ti/ti-codec.inc
new file mode 100644 (file)
index 0000000..655e9d1
--- /dev/null
@@ -0,0 +1,12 @@
+DESCRIPTION = "TI Codec for ${MACHINE_ARCH}"
+
+require ti-paths.inc
+
+do_stage() {
+    install -d ${CODEC_INSTALL_DIR}
+    cp -pPrf ${S}/* ${CODEC_INSTALL_DIR}
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+FILES_${PN} = "${installdir}/codec-combo/*"
+