pvr-init: Removed check for CPU (as TI has changed the CPU Type...)
authorMichael Mrozek <EvilDragon@openpandora.de>
Thu, 19 Jul 2012 23:28:56 +0000 (01:28 +0200)
committerMichael Mrozek <EvilDragon@openpandora.de>
Thu, 19 Jul 2012 23:28:56 +0000 (01:28 +0200)
recipes/powervr-drivers/libgles-omap3/rc.pvr
recipes/powervr-drivers/libgles-omap3_4.00.00.01.bb

index 38697eb..f550624 100755 (executable)
@@ -30,7 +30,6 @@ fi
 # Try to enable triple buffering when there's enough VRAM
 fbset -vyres $(expr $YRES \* 3) 
 
-if [ $CPUTYPE = "OMAP3530" ]; then
        echo Starting PVR
        insmod /lib/modules/$(uname -r)/kernel/drivers/gpu/pvr/pvrsrvkm.ko
        insmod /lib/modules/$(uname -r)/kernel/drivers/gpu/pvr/omaplfb.ko
@@ -72,7 +71,3 @@ if [ $CPUTYPE = "OMAP3530" ]; then
                echo "${ES_REVISION}" > /etc/powervr-esrev
        fi
        /usr/bin/pvrsrvinit
-else
-       echo No SGX hardware, not starting PVR
-fi
-
index 966f8d1..c8ba146 100644 (file)
@@ -10,7 +10,7 @@ require libgles-omap3.inc
 # http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
 # see libgles-omap3.inc for detailed installation instructions
 
-PR = "r5"
+PR = "r6"
 
 SGXPV = "4_00_00_01"
 IMGPV = "1.4.14.2616"