wireless-tools: use LDFLAGS (fixes QA error)
authorJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 09:24:54 +0000 (09:24 +0000)
committerJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 09:24:54 +0000 (09:24 +0000)
recipes/wireless-tools/wireless-tools.inc
recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch [new file with mode: 0644]
recipes/wireless-tools/wireless-tools_29.bb

index 36ee3ed..d2a7b89 100644 (file)
@@ -7,6 +7,7 @@ LICENSE = "GPL"
 SRC_URI += "\
   http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/wireless_tools.${PV}.tar.gz \
   file://man.patch;patch=1 \
+  file://shared_lib_ldflags.patch;patch=1 \
   file://wireless-tools.if-pre-up \
   file://zzz-wireless.if-pre-up"
 S = "${WORKDIR}/wireless_tools.${PV}"
diff --git a/recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch b/recipes/wireless-tools/wireless-tools/shared_lib_ldflags.patch
new file mode 100644 (file)
index 0000000..85abde0
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN wireless_tools.29.orig/Makefile wireless_tools.29/Makefile
+--- wireless_tools.29.orig/Makefile    2007-09-17 23:56:46.000000000 +0000
++++ wireless_tools.29/Makefile 2009-04-02 09:22:14.000000000 +0000
+@@ -145,7 +145,7 @@
+ # Compilation of the dynamic library
+ $(DYNAMIC): $(OBJS:.o=.so)
+-      $(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
++      $(CC) $(LDFLAGS) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
+ # Compilation of the static library
+ $(STATIC): $(OBJS:.o=.so)