mtools: don't install-info; fixes build on non-Debian hosts
authorMichael Smith <msmith@cbnco.com>
Mon, 17 Aug 2009 03:29:02 +0000 (03:29 +0000)
committerHolger Hans Peter Freyther <zecke@selfish.org>
Tue, 18 Aug 2009 14:12:57 +0000 (16:12 +0200)
The install-info installed into staging by dpkg-native looks for
/var/backups/infodir.bak and /usr/share/base-files/info.dir on
the build system. On Debian/Ubuntu this is benign, but on other
distros these files don't exist and the install fails.

The info file is still installed, we just don't try to rebuild the
nonexistent directory.

There are cleaner ways to solve this in the long run:

http://dev.openbossa.org/trac/mamona/ticket/139

Signed-off-by: Michael Smith <msmith@cbnco.com>
Signed-off-by: Holger Freyther <zecke@selfish.org>
recipes/mtools/mtools_4.0.10.bb

index b53306a..18fbb7d 100644 (file)
@@ -13,12 +13,15 @@ SRC_URI="http://ftp.gnu.org/gnu/mtools/mtools-${PV}.tar.bz2 \
        file://plainio.patch;patch=1 \
        file://use-sg_io.patch;patch=1"
 
-S = "${WORKDIR}/mtools-${PV}"
+PR = "r1"
 
 inherit autotools
 
 EXTRA_OECONF = "--without-x"
 
+# Don't try to run install-info -- it'll fail on non-Debian build systems.
+EXTRA_OEMAKE = "INSTALL_INFO="
+
 do_fix_perms() {
        chmod 644 ${S}/*.c ${S}/*.h
 }