agg-2.5: Fix typoin CFLAGS. Provide X paths to configure.
authorLeon Woestenberg <leon@sidebranch.com>
Sun, 18 Oct 2009 13:36:32 +0000 (15:36 +0200)
committerLeon Woestenberg <leon@sidebranch.com>
Sun, 18 Oct 2009 19:08:42 +0000 (21:08 +0200)
There is a typo in the CFLAGS. Additionally a fix is needed to
have the X library paths configured correctly.

Fixed and tested for MACHINE=beagleboard.

Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
recipes/agg/agg_2.5.bb

index ba76a7b..1129ea5 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs"
 LICENSE = "AGG License"
 DEPENDS = "virtual/libx11 virtual/libsdl freetype"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://www.antigrain.com/${P}.tar.gz"
 S = "${WORKDIR}/${P}"
@@ -14,7 +14,7 @@ inherit autotools pkgconfig
 
 export SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config
 
-CFLAGS += " -I{$STAGING_INCDIR} "
+CFLAGS += " -I${STAGING_INCDIR} "
 
 PACKAGES =+ "${PN}-sdl ${PN}-x11"
 
@@ -25,6 +25,8 @@ FILES_${PN} = "${libdir}/libagg.so.* \
 
 LEAD_SONAME = "libagg.so"
 
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/usr/include --x-libraries=${STAGING_INCDIR}/usr/lib"
+
 do_stage() {
     oe_libinstall -a -so libagg ${STAGING_LIBDIR}
     oe_libinstall -a -so libaggfontfreetype ${STAGING_LIBDIR}