libgee: refactor into common inc file and add 0.5.2 release
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Mon, 2 Aug 2010 19:43:12 +0000 (21:43 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Mon, 2 Aug 2010 19:43:39 +0000 (21:43 +0200)
recipes/libgee/libgee.inc [new file with mode: 0644]
recipes/libgee/libgee_0.5.2.bb [new file with mode: 0644]
recipes/libgee/libgee_git.bb

diff --git a/recipes/libgee/libgee.inc b/recipes/libgee/libgee.inc
new file mode 100644 (file)
index 0000000..208e4e9
--- /dev/null
@@ -0,0 +1,11 @@
+DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
+and classes for commonly used data structures."
+HOMEPAGE = "http://live.gnome.org/Libgee"
+SECTION = "libs"
+DEPENDS = "glib-2.0"
+BBCLASSEXTEND = "native"
+DEPENDS_virtclass-native = "glib-2.0-native"
+LICENSE = "LGPL"
+PE = "1"
+
+inherit autotools vala
diff --git a/recipes/libgee/libgee_0.5.2.bb b/recipes/libgee/libgee_0.5.2.bb
new file mode 100644 (file)
index 0000000..b256baf
--- /dev/null
@@ -0,0 +1,16 @@
+require libgee.inc
+PE = "1"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/0.5/${P}.tar.bz2"
+S = "${WORKDIR}/libgee-${PV}"
+
+SRC_URI[md5sum] = "fc5a36eb5f61154a1456cbb8b1798e41"
+SRC_URI[sha256sum] = "8625ebfb479600046b9e36e1a8fd1142d624645dce66a6cd8c9067d8f7f5ce51"
+
+inherit autotools vala
+
+do_configure() {
+       gnu-configize
+       oe_runconf
+}
+
index 52405ee..66d2ac7 100644 (file)
@@ -1,18 +1,12 @@
-DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
-and classes for commonly used data structures."
-HOMEPAGE = "http://live.gnome.org/Libgee"
-SECTION = "libs"
-DEPENDS = "glib-2.0"
-BBCLASSEXTEND = "native"
-DEPENDS_virtclass-native = "glib-2.0-native"
-LICENSE = "LGPL"
+require libgee.inc
+
 SRCREV = "3c3af3ecc99bc130643c2b372164e987a5a261a9"
 PV = "0.5.1+gitr${SRCPV}"
 PE = "1"
 
+DEFAULT_PREFERENCE = "-1"
+
 SRC_URI = "\
   git://git.gnome.org/libgee;protocol=git;branch=master \
 "
 S = "${WORKDIR}/git"
-
-inherit autotools vala