logkit 1.2.2: New recipe (from Jalimo SVN).
authorRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 12:39:36 +0000 (14:39 +0200)
committerRobert Schuster <robertschuster@fsfe.org>
Fri, 18 Sep 2009 12:39:36 +0000 (14:39 +0200)
logkit-native 1.2.2: Dito.

recipes/jakarta-libs/logkit-native_1.2.2.bb [new file with mode: 0644]
recipes/jakarta-libs/logkit_1.2.2.bb [new file with mode: 0644]

diff --git a/recipes/jakarta-libs/logkit-native_1.2.2.bb b/recipes/jakarta-libs/logkit-native_1.2.2.bb
new file mode 100644 (file)
index 0000000..479f597
--- /dev/null
@@ -0,0 +1,6 @@
+require logkit_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native oro-native servlet2.3-native gnumail-native gnujaf-native log4j1.2-native avalon-framework-api-native"
+
diff --git a/recipes/jakarta-libs/logkit_1.2.2.bb b/recipes/jakarta-libs/logkit_1.2.2.bb
new file mode 100644 (file)
index 0000000..58d496c
--- /dev/null
@@ -0,0 +1,25 @@
+DESCRIPTION = "Logging toolkit designed for secure performance orientated logging in Java applications"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://www.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/${BP}-dev"
+
+DEPENDS = "fastjar-native oro servlet2.3 gnumail gnujaf log4j1.2 avalon-framework-api"
+
+do_compile() {
+  mkdir -p build
+
+  oe_makeclasspath cp -s oro servlet-2.3 activation gnumail log4j-1.2 avalon-framework-api
+
+  # Built everything but the JMS and JMX classes (like in Debian)
+  javac -encoding ISO8859-1 -sourcepath src/java -cp $cp -d build \
+    `find src/java -name \*.java -and -not \( -iwholename "*jms*" -or -wholename "*test*" \)`
+
+  (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
+
+  fastjar -C build -c -f ${JARFILENAME} .
+}