libgles-omap3: add 4.00.00.01 release
authorRoger Monk <r-monk@ti.com>
Thu, 30 Sep 2010 19:14:10 +0000 (19:14 +0000)
committerGrazvydas Ignotas <notasas@gmail.com>
Sat, 22 Jan 2011 22:14:31 +0000 (00:14 +0200)
* this doesn't support ES6.x (aka netra) yet in the recipe, but the support is present in the .bin

Signed-off-by: Roger Monk <r-monk@ti.com>
Signed-off-by: Koen Kooi <k-kooi@ti.com>
recipes/powervr-drivers/libgles-omap3_4.00.00.01.bb [new file with mode: 0644]

diff --git a/recipes/powervr-drivers/libgles-omap3_4.00.00.01.bb b/recipes/powervr-drivers/libgles-omap3_4.00.00.01.bb
new file mode 100644 (file)
index 0000000..fbecccc
--- /dev/null
@@ -0,0 +1,28 @@
+BINLOCATION = "${S}/gfx_rel_es3.x"
+
+ES2LOCATION = "${S}/gfx_rel_es2.x"
+ES3LOCATION = "${S}/gfx_rel_es3.x"
+ES5LOCATION = "${S}/gfx_rel_es5.x"
+
+require libgles-omap3.inc
+
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
+# see libgles-omap3.inc for detailed installation instructions
+
+SGXPV = "4_00_00_01"
+IMGPV = "1.4.14.2616"
+BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
+                   file://cputype \
+                   file://rc.pvr \
+                   file://sample.desktop \
+                   file://99-bufferclass.rules  \
+"
+
+SRC_URI[md5sum] = "a027002dcd7164df467b1a315788d5fd"
+SRC_URI[sha256sum] = "62383d15e33adf9349afba063b0f2405a15aa6c4b0b5579b0abdf81db7580df7"
+
+S = "${WORKDIR}/Graphics_SDK_${SGXPV}"
+