libsdl-mixer: fix flac madness
authorKoen Kooi <koen@openembedded.org>
Wed, 2 Dec 2009 15:26:41 +0000 (16:26 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 2 Dec 2009 15:26:41 +0000 (16:26 +0100)
recipes/libsdl/libsdl-mixer/fix-flac-madness.diff [new file with mode: 0644]
recipes/libsdl/libsdl-mixer_1.2.11.bb

diff --git a/recipes/libsdl/libsdl-mixer/fix-flac-madness.diff b/recipes/libsdl/libsdl-mixer/fix-flac-madness.diff
new file mode 100644 (file)
index 0000000..48fe88e
--- /dev/null
@@ -0,0 +1,28 @@
+--- /tmp/configure.in  2009-12-02 16:18:33.000000000 +0100
++++ SDL_mixer-1.2.11/configure.in      2009-12-02 16:20:02.000000000 +0100
+@@ -413,24 +413,7 @@
+               [], [enable_music_flac_shared=yes])
+ if test x$enable_music_flac = xyes; then
+     AC_CHECK_HEADER([FLAC/export.h], [have_flac_export=yes])
+-    if test x$have_flac_export = xyes; then
+-        LIBS_SAVED="$LIBS"
+-        LIBS="-lFLAC"
+-        AC_MSG_CHECKING([for libflac so-name version >= $libflac_ver])
+-        AC_TRY_RUN([
+-#include "FLAC/export.h"
+-#include "stdio.h"
+-int main( int argc, char *argv[] ) {
+-#if defined(FLAC_API_VERSION_CURRENT) && (FLAC_API_VERSION_CURRENT >= $libflac_ver)
+-    return 0;
+-#else
+-    return 1;
+-#endif
+-}
+-], have_flac_ver=yes, have_flac_ver=no)
+-        LIBS="$LIBS_SAVED"
+-        AC_MSG_RESULT($have_flac_ver)
+-    fi
++      have_flac_ver=yes
+     if test x$have_flac_ver = xyes; then
+         AC_CHECK_HEADER([FLAC/stream_decoder.h], [have_flac_hdr=yes])
index 5ecd294..ee0ba45 100644 (file)
@@ -1,10 +1,14 @@
 DESCRIPTION = "Simple DirectMedia Layer mixer library."
 SECTION = "libs"
 PRIORITY = "optional"
-DEPENDS = "virtual/libsdl libmikmod libvorbis"
+DEPENDS = "virtual/libsdl flac libmikmod libvorbis"
 LICENSE = "LGPL"
 
-SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+PR = "r1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
+           file://fix-flac-madness.diff;patch=1"
+
 S = "${WORKDIR}/SDL_mixer-${PV}"
 
 export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"